High severity vulnerability that affects generator-jhipster
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (generator-jhipster 6.3.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 6.3.1
- Fixed in
- 6.3.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mc84-xr9p-938r lists affected ranges: npm generator-jhipster >=0 <6.3.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mc84-xr9p-938r lists affected ranges: npm generator-jhipster >=0 <6.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Generated code uses repository configuration that downloads over HTTP instead of HTTPS Impact Gradle users were using the http://repo.spring.io/plugins-release repositories in plain HTTP, and not HTTPS, so a man-in-the-middle attack was possible at build time. Patches Maven users should at least upgrade to 6.3.0 while Gradle users should update to 6.3.1. If you are not able to upgrade make sure not to use a Maven repository via http in your build file. Workarounds Replace all custom repository definitions in build.gradle or pom.xml with their https version. e.g. References https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator?vector=AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H https://max.computer/blog/how-to-take-over-the-computer-of-any-java-or-clojure-or-scala-developer/ For more information If you have any questions or comments about this advisory: Open an issue in https://github.com/jhipster/generator-jhipster/issues
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mc84-xr9p-938r
- Revision 1 · created ·
Published from osv record GHSA-mc84-xr9p-938r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-mc84-xr9p-938r Advisory: High severity vulnerability that affects generator-jhipster IDs: GHSA-mc84-xr9p-938r Record: https://patchnext.com/advisories/ghsa-mc84-xr9p-938r (revision 2, source checked 26 Oct 2026, 12:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: generator-jhipster 6.3.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm generator-jhipster: affected < 6.3.1; fixed in 6.3.1 ## Suggested inspection (read-only) - `npm ls generator-jhipster --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on generator-jhipster. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mc84-xr9p-938r (OSV record GHSA-mc84-xr9p-938r lists affected ranges: npm generator-jhipster >=0 <6.3.1 (fixed)) - Verified: https://github.com/advisories/GHSA-mc84-xr9p-938r (GitHub-reviewed advisory GHSA-mc84-xr9p-938r lists affected ranges: npm generator-jhipster >=0 <6.3.1) Commands are suggestions: review each one before running it.
Loading voting…