Skip to content

← Actionable
Medium, CVSS 6.9

Diesel: Command injection in Diesel's implementation of COPY FROM/COPY TO

GHSA-m9p2-fxp5-v3fp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (diesel 2.3.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io diesel

    Affected
    < 2.3.8
    Fixed in
    2.3.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Diesel allows users to configure various options for PostgreSQL's COPY FROM and COPY TO statements. These configurations are partially provided as strings or characters. Diesel did not check if any these user-provided options contain a quote character ', which can lead to the injection of additional options in the current COPY FROM/COPY TO statement. This vulnerability affects any user of COPY FROM/COPY TO that passes user-provided input to any of the affected functions. It can result in modifications of options in the current statement, but it is not possible inject additional statements. Mitigation The preferred mitigation to the outlined problem is to update to Diesel version 2.3.8 or newer, which includes fixes for the problem. Resolution Diesel now correctly escapes any quotes contained in the provided arguments.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m9p2-fxp5-v3fp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-m9p2-fxp5-v3fp

Advisory: Diesel: Command injection in Diesel's implementation of `COPY FROM`/`COPY TO`
IDs: GHSA-m9p2-fxp5-v3fp
Record: https://patchnext.com/advisories/ghsa-m9p2-fxp5-v3fp (revision 1, source checked 26 Oct 2026, 15:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: diesel 2.3.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io diesel: affected < 2.3.8; fixed in 2.3.8

## Suggested inspection (read-only)
- crates.io diesel: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on diesel.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m9p2-fxp5-v3fp (GitHub-reviewed advisory GHSA-m9p2-fxp5-v3fp lists affected ranges: crates.io diesel >=0 <2.3.8)

Commands are suggestions: review each one before running it.

Loading voting…