Skip to content

← Actionable
Medium, CVSS 6.1

Silverstripe XSS in CMS Edit Page

GHSA-m8v7-x398-pxrf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/framework 3.3.2, 3.2.4, 3.1.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist silverstripe/framework

    Affected
    >= 3.1.18, < 3.1.19>= 3.2.3, < 3.2.4>= 3.3.1, < 3.3.2
    Fixed in
    3.2.4, 3.1.19, 3.3.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Due to a lack of parameter sanitisation a carefully crafted URL could be used to inject arbitrary HTML into the CMS Edit page. An attacker could create a URL and share it with a site administrator to perform an attack.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m8v7-x398-pxrf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-m8v7-x398-pxrf

Advisory: Silverstripe XSS in CMS Edit Page
IDs: GHSA-m8v7-x398-pxrf
Record: https://patchnext.com/advisories/ghsa-m8v7-x398-pxrf (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: silverstripe/framework 3.3.2, 3.2.4, 3.1.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist silverstripe/framework: affected >= 3.1.18, < 3.1.19; >= 3.2.3, < 3.2.4; >= 3.3.1, < 3.3.2; fixed in 3.2.4, 3.1.19, 3.3.2

## Suggested inspection (read-only)
- Packagist silverstripe/framework: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on silverstripe/framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m8v7-x398-pxrf (GitHub-reviewed advisory GHSA-m8v7-x398-pxrf lists affected ranges: Packagist silverstripe/framework >=3.1.18 =3.2.3 =3.3.1 <3.3.2)

Commands are suggestions: review each one before running it.

Loading voting…