Shopware vulnerable to MediaVisibilityRestrictionSubscriber bypass when reading media entities by aggregating fields individually
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopware/core 6.7.3.1, 6.6.10.7; shopware/platform 6.7.3.1, 6.6.10.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist shopware/core
- Affected
- >= 6.7.0.0, < 6.7.3.1< 6.6.10.7
- Fixed in
- 6.7.3.1, 6.6.10.7
Packagist shopware/platform
- Affected
- >= 6.7.0.0, < 6.7.3.1< 6.6.10.7
- Fixed in
- 6.7.3.1, 6.6.10.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m895-2hj3-8cg9 lists affected ranges: Packagist shopware/platform >=6.7.0.0 =0 =6.7.0.0 =0 <6.6.10.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
In Shopware core and platform versions before 6.6.10.7 and 6.7.3.1, media visibility restrictions applied by MediaVisibilityRestrictionSubscriber are not enforced for aggregation API requests. Authorization filters are only injected during standard entity reads; aggregation queries can be constructed to bypass these checks and enumerate private media records such as invoices or other restricted documents. A low‑privilege backend user (e.g., product editor) can chain normal business flows (creating or viewing orders) with aggregation queries to disclose sensitive customer data including addresses and payment-related information contained within associated private media. The issue is resolved in 6.6.10.7 and 6.7.3.1.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m895-2hj3-8cg9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-m895-2hj3-8cg9 Advisory: Shopware vulnerable to MediaVisibilityRestrictionSubscriber bypass when reading media entities by aggregating fields individually IDs: GHSA-m895-2hj3-8cg9 Record: https://patchnext.com/advisories/ghsa-m895-2hj3-8cg9 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: shopware/core 6.7.3.1, 6.6.10.7; shopware/platform 6.7.3.1, 6.6.10.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist shopware/core: affected >= 6.7.0.0, < 6.7.3.1; < 6.6.10.7; fixed in 6.7.3.1, 6.6.10.7 - Packagist shopware/platform: affected >= 6.7.0.0, < 6.7.3.1; < 6.6.10.7; fixed in 6.7.3.1, 6.6.10.7 ## Suggested inspection (read-only) - Packagist shopware/core: check the installed version with your package manager. - Packagist shopware/platform: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on shopware/core, shopware/platform. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m895-2hj3-8cg9 (GitHub-reviewed advisory GHSA-m895-2hj3-8cg9 lists affected ranges: Packagist shopware/platform >=6.7.0.0 =0 =6.7.0.0 =0 <6.6.10.7) Commands are suggestions: review each one before running it.
Loading voting…