Skip to content

← Actionable
Critical, CVSS 9.8amended

Malicious Package in eslint-config-airbnb-standard

GHSA-m852-866j-69j8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (eslint-config-airbnb-standard 2.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Version 2.0.0 of eslint-config-airbnb-standard was published with a bundled version of eslint-scope that was found to contain malicious code. This code would read the users .npmrc file and send it's contents to a remote server. Recommendation The best course of action if you found this package installed in your environment is to revoke all your npm tokens and use a different version of the module. You can find instructions on how to do that here. https://docs.npmjs.com/getting-started/workingwithtokens#how-to-revoke-tokens

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-m852-866j-69j8

  2. Revision 1 · created ·

    Published from osv record GHSA-m852-866j-69j8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-m852-866j-69j8

Advisory: Malicious Package in eslint-config-airbnb-standard
IDs: GHSA-m852-866j-69j8
Record: https://patchnext.com/advisories/ghsa-m852-866j-69j8 (revision 2, source checked 26 Oct 2026, 12:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: eslint-config-airbnb-standard 2.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm eslint-config-airbnb-standard: affected >= 2.0.0, <= 2.0.0; fixed in 2.1.0

## Suggested inspection (read-only)
- `npm ls eslint-config-airbnb-standard --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on eslint-config-airbnb-standard.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m852-866j-69j8 (OSV record GHSA-m852-866j-69j8 lists affected ranges: npm eslint-config-airbnb-standard >=2.0.0 <2.1.0 (fixed))
- Verified: https://github.com/advisories/GHSA-m852-866j-69j8 (GitHub-reviewed advisory GHSA-m852-866j-69j8 lists affected ranges: npm eslint-config-airbnb-standard >=2.0.0 <=2.0.0)

Commands are suggestions: review each one before running it.

Loading voting…