Skip to content

← Actionable
Medium, CVSS 6.0

SurrealDB vulnerable to memory exhaustion via nested functions and scripts

GHSA-m7rc-8w7m-r9qr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (surrealdb 2.2.2, 2.1.5, 2.0.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io surrealdb

    Affected
    >= 2.2.0, < 2.2.2>= 2.1.0, < 2.1.5< 2.0.5
    Fixed in
    2.1.5, 2.2.2, 2.0.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

In order to prevent DoS situations due to infinite recursions, SurrealDB implements a limit of nested calls for both native functions and embedded JavaScript functions. However, in SurrealDB instances with embedded scripting functions enabled, it was found that this limit can be circumvented by utilizing both at the same time. If a native function contains JavaScript which issues a new query that calls that function, the recursion limit is not triggered. Once executed, SurrealDB will follow the path of infinite recursions until the system runs out of memory, prior to the recursion limit being triggered. This vulnerability can only affect SurrealDB servers explicitly enabling the scripting capability with --allow-scripting or --allow-all and equivalent environment variables SURREALCAPSALLOWSCRIPT=true and SURREALCAPSALLOWALL=true. This issue was discovered and patched during an code audit and penetration test of SurrealDB by cure53, the severity defined within cure53's preliminary…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m7rc-8w7m-r9qr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-m7rc-8w7m-r9qr

Advisory: SurrealDB vulnerable to memory exhaustion via nested functions and scripts
IDs: GHSA-m7rc-8w7m-r9qr
Record: https://patchnext.com/advisories/ghsa-m7rc-8w7m-r9qr (revision 1, source checked 26 Oct 2026, 15:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: surrealdb 2.2.2, 2.1.5, 2.0.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io surrealdb: affected >= 2.2.0, < 2.2.2; >= 2.1.0, < 2.1.5; < 2.0.5; fixed in 2.1.5, 2.2.2, 2.0.5

## Suggested inspection (read-only)
- crates.io surrealdb: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on surrealdb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m7rc-8w7m-r9qr (GitHub-reviewed advisory GHSA-m7rc-8w7m-r9qr lists affected ranges: crates.io surrealdb >=2.2.0 =2.1.0 =0 <2.0.5)

Commands are suggestions: review each one before running it.

Loading voting…