S3 storage write is not aborted on errors leading to unbounded memory usage
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/foxcpp/maddy 0.5.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.5.1
- Fixed in
- 0.5.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m6m5-pp4g-fcc8 lists affected ranges: Go github.com/foxcpp/maddy >=0 <0.5.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact Anyone using storage.blob.s3 introduced in 0.5.0 with storage.imapsql. Patches The relevant commit is pushed to master and will be included in the 0.5.1 release. No special handling of the issue has been done due to the small amount of affected users. Workarounds None. References Original report: https://github.com/foxcpp/maddy/issues/395 Fix: https://github.com/foxcpp/maddy/commit/07c8495ee4394fabbf5aac4df8aebeafb2fb29d8
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m6m5-pp4g-fcc8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-m6m5-pp4g-fcc8 Advisory: S3 storage write is not aborted on errors leading to unbounded memory usage IDs: GHSA-m6m5-pp4g-fcc8 Record: https://patchnext.com/advisories/ghsa-m6m5-pp4g-fcc8 (revision 1, source checked 26 Oct 2026, 14:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/foxcpp/maddy 0.5.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/foxcpp/maddy: affected < 0.5.1; fixed in 0.5.1 ## Suggested inspection (read-only) - Go github.com/foxcpp/maddy: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/foxcpp/maddy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m6m5-pp4g-fcc8 (GitHub-reviewed advisory GHSA-m6m5-pp4g-fcc8 lists affected ranges: Go github.com/foxcpp/maddy >=0 <0.5.1) Commands are suggestions: review each one before running it.
Loading voting…