Skip to content

← Actionable
Critical, CVSS 10.0

Islandora 2.0 before 2.4.1 could allow any user to upload content into a repository

GHSA-m58q-qq5h-mgqq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (islandora/islandora 2.4.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact This vulnerability would allow any user, regardless of permissions, to upload content into a repository. This affects installations of Islandora core 2.0 or greater. Patches Upgrade immediately to the latest release of Islandora. Workarounds In lieu of an upgrade the following module can be leveraged that will resolve the issue until such a time an upgrade can take place. For more information If you have any questions or comments about this advisory: Open an issue in Islandora Contact community@islandora.ca.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m58q-qq5h-mgqq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-m58q-qq5h-mgqq

Advisory: Islandora 2.0 before 2.4.1 could allow any user to upload content into a repository
IDs: GHSA-m58q-qq5h-mgqq
Record: https://patchnext.com/advisories/ghsa-m58q-qq5h-mgqq (revision 1, source checked 26 Oct 2026, 13:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: islandora/islandora 2.4.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist islandora/islandora: affected >= 2.0, < 2.4.1; fixed in 2.4.1

## Suggested inspection (read-only)
- Packagist islandora/islandora: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on islandora/islandora.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m58q-qq5h-mgqq (GitHub-reviewed advisory GHSA-m58q-qq5h-mgqq lists affected ranges: Packagist islandora/islandora >=2.0 <2.4.1)

Commands are suggestions: review each one before running it.

Loading voting…