Prototype pollution vulnerability found in Mermaid's bundled version of DOMPurify
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mermaid 10.9.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm mermaid
- Affected
- <= 10.9.2
- Fixed in
- 10.9.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m4gq-x24j-jpmf lists affected ranges: npm mermaid >=0 <10.9.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m4gq-x24j-jpmf lists affected ranges: npm mermaid >=0 <=10.9.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:L
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
The following bundled files within the Mermaid NPM package contain a bundled version of DOMPurify that is vulnerable to https://github.com/cure53/DOMPurify/security/advisories/GHSA-mmhx-hmjr-r674, potentially resulting in an XSS attack. This affects the built: - dist/mermaid.min.js - dist/mermaid.js - dist/mermaid.esm.mjs - dist/mermaid.esm.min.mjs This will also affect users that use the above files via a CDN link, e.g. https://cdn.jsdelivr.net/npm/mermaid@10.9.2/dist/mermaid.min.js Users that use the default NPM export of mermaid, e.g. import mermaid from 'mermaid', or the dist/mermaid.core.mjs file, do not use this bundled version of DOMPurify, and can easily update using their package manager with something like npm audit fix. Patches - develop branch: 6c785c93166c151d27d328ddf68a13d9d65adc00 - backport to v10: 92a07ffe40aab2769dd1c3431b4eb5beac282b34
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-m4gq-x24j-jpmf
- Revision 1 · created ·
Published from osv record GHSA-m4gq-x24j-jpmf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-m4gq-x24j-jpmf Advisory: Prototype pollution vulnerability found in Mermaid's bundled version of DOMPurify IDs: GHSA-m4gq-x24j-jpmf Record: https://patchnext.com/advisories/ghsa-m4gq-x24j-jpmf (revision 2, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mermaid 10.9.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm mermaid: affected <= 10.9.2; fixed in 10.9.3 ## Suggested inspection (read-only) - `npm ls mermaid --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mermaid. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m4gq-x24j-jpmf (OSV record GHSA-m4gq-x24j-jpmf lists affected ranges: npm mermaid >=0 <10.9.3 (fixed)) - Verified: https://github.com/advisories/GHSA-m4gq-x24j-jpmf (GitHub-reviewed advisory GHSA-m4gq-x24j-jpmf lists affected ranges: npm mermaid >=0 <=10.9.2) Commands are suggestions: review each one before running it.
Loading voting…