git2-rs fails to verify SSH keys by default
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (libgit2-sys 0.14.2, 0.13.5; git2 0.16.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io libgit2-sys
- Affected
- >= 0.14.0, < 0.14.2< 0.13.5
- Fixed in
- 0.13.5, 0.14.2
crates.io git2
- Affected
- < 0.16.1
- Fixed in
- 0.16.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m4ch-rfv5-x5g3 lists affected ranges: crates.io libgit2-sys >=0.14.0 =0 =0 <0.16.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
The git2 and libgit2-sys crates are Rust wrappers around the libgit2 C library. It was discovered that libgit2 1.5.0 and below did not verify SSH host keys when establishing an SSH connection, exposing users of the library to Man-In-the-Middle attacks. The libgit2 team assigned CVE-2023-22742 to this vulnerability. The following versions of the libgit2-sys Rust crate have been released: libgit2-sys 0.14.2, updating the underlying libgit2 C library to version 1.5.1. libgit2-sys 0.13.5, updating the underlying libgit2 C library to version 1.4.5. A new git2 crate version has also been released, 0.16.1. This version only bumps its libgit2-sys dependency to ensure no vulnerable libgit2-sys versions are used, but contains no code changes: if you update the libgit2-sys version there is no need to also update the git2 crate version. You can learn more about this vulnerability in libgit2's advisory
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m4ch-rfv5-x5g3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-m4ch-rfv5-x5g3 Advisory: git2-rs fails to verify SSH keys by default IDs: GHSA-m4ch-rfv5-x5g3 Record: https://patchnext.com/advisories/ghsa-m4ch-rfv5-x5g3 (revision 1, source checked 26 Oct 2026, 15:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: libgit2-sys 0.14.2, 0.13.5; git2 0.16.1. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io libgit2-sys: affected >= 0.14.0, < 0.14.2; < 0.13.5; fixed in 0.13.5, 0.14.2 - crates.io git2: affected < 0.16.1; fixed in 0.16.1 ## Suggested inspection (read-only) - crates.io libgit2-sys: check the installed version with your package manager. - crates.io git2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on libgit2-sys, git2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m4ch-rfv5-x5g3 (GitHub-reviewed advisory GHSA-m4ch-rfv5-x5g3 lists affected ranges: crates.io libgit2-sys >=0.14.0 =0 =0 <0.16.1) Commands are suggestions: review each one before running it.
Loading voting…