Skip to content

← Actionable
High, CVSS 7.5

gRPC-Go HTTP/2 Rapid Reset vulnerability

GHSA-m425-mq94-257g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (google.golang.org/grpc 1.58.3, 1.57.1, 1.56.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact In affected releases of gRPC-Go, it is possible for an attacker to send HTTP/2 requests, cancel them, and send subsequent requests, which is valid by the HTTP/2 protocol, but would cause the gRPC-Go server to launch more concurrent method handlers than the configured maximum stream limit. Patches This vulnerability was addressed by #6703 and has been included in patch releases: 1.56.3, 1.57.1, 1.58.3. It is also included in the latest release, 1.59.0. Along with applying the patch, users should also ensure they are using the grpc.MaxConcurrentStreams server option to apply a limit to the server's resources used for any single connection. Workarounds None. References #6703

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m425-mq94-257g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-m425-mq94-257g

Advisory: gRPC-Go HTTP/2 Rapid Reset vulnerability
IDs: GHSA-m425-mq94-257g
Record: https://patchnext.com/advisories/ghsa-m425-mq94-257g (revision 1, source checked 26 Oct 2026, 15:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: google.golang.org/grpc 1.58.3, 1.57.1, 1.56.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go google.golang.org/grpc: affected < 1.56.3; >= 1.57.0, < 1.57.1; >= 1.58.0, < 1.58.3; fixed in 1.58.3, 1.57.1, 1.56.3

## Suggested inspection (read-only)
- Go google.golang.org/grpc: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on google.golang.org/grpc.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m425-mq94-257g (GitHub-reviewed advisory GHSA-m425-mq94-257g lists affected ranges: Go google.golang.org/grpc >=0 =1.57.0 =1.58.0 <1.58.3)

Commands are suggestions: review each one before running it.

Loading voting…