Skip to content

← Actionable
High, CVSS 8.1amended

@evomap/evolver's validator sandbox allowlist permits npm/npx, yielding RCE from Hub-delivered validation tasks via lifecycle scripts

GHSA-jxh8-jh77-xh6g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@evomap/evolver 1.70.0-beta.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary The validator-mode sandbox executor (src/gep/validator/sandboxExecutor.js) places npm and npx in its hard executable allowlist. Because npm install <pkg and npx -y -p <pkg <bin execute arbitrary code by design (preinstall/install/postinstall lifecycle scripts and remote-package bin entries), and because validator nodes consume validationcommands strings from unsigned Hub responses with no per-response signature check, an attacker who controls or MITMs the Hub achieves automatic remote code execution on every validator node within one daemon poll (default 60s). Details End-to-end chain: 1. src/gep/validator/index.js:71-87 — fetchValidationTasks() POSTs to <hub/a2a/fetch and reads validationtasks from the JSON response. The outbound request is signed via buildHubHeaders(), but the Hub's response is parsed directly with await res.json() and no signature is verified on data.payload. 2. src/gep/validator/index.js:98-108 — validateOneTask() extracts task.validationcommands (an…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jxh8-jh77-xh6g

  2. Revision 1 · created ·

    Published from osv record GHSA-jxh8-jh77-xh6g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-jxh8-jh77-xh6g

Advisory: @evomap/evolver's validator sandbox allowlist permits `npm`/`npx`, yielding RCE from Hub-delivered validation tasks via lifecycle scripts
IDs: GHSA-jxh8-jh77-xh6g
Record: https://patchnext.com/advisories/ghsa-jxh8-jh77-xh6g (revision 2, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @evomap/evolver 1.70.0-beta.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @evomap/evolver: affected <= 1.70.0-beta.4; fixed in 1.70.0-beta.5

## Suggested inspection (read-only)
- `npm ls @evomap/evolver --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @evomap/evolver.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jxh8-jh77-xh6g (OSV record GHSA-jxh8-jh77-xh6g lists affected ranges: npm @evomap/evolver >=0 <1.70.0-beta.5 (fixed))
- Verified: https://github.com/advisories/GHSA-jxh8-jh77-xh6g (GitHub-reviewed advisory GHSA-jxh8-jh77-xh6g lists affected ranges: npm @evomap/evolver >=0 <=1.70.0-beta.4)

Commands are suggestions: review each one before running it.

Loading voting…