SIPSorcery vulnerable to Denial of Service via out-of-bounds read in SCTP SACK chunk parsing
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sipsorcery 10.0.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet sipsorcery
- Affected
- <= 10.0.13
- Fixed in
- 10.0.14
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jwjp-4649-v8jp lists affected ranges: NuGet sipsorcery >=0 <10.0.14 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jwjp-4649-v8jp lists affected ranges: NuGet sipsorcery >=0 <=10.0.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary SctpSackChunk.ParseChunk reads the numGapAckBlocks and numDuplicateTSNs fields (each up to 65535) directly from an attacker-controlled SCTP SACK chunk and loops that many times reading 4 bytes per iteration, with no validation of the counts against the chunk length or the receive buffer. A single crafted SACK chunk from a negotiated WebRTC peer forces reads past the end of the 262144-byte receive buffer, raising IndexOutOfRangeException, which is not caught by the recoverable handler and terminates the dedicated SCTP receive thread — permanently killing the SCTP association and all data channels. Root Cause src/SIPSorcery/net/SCTP/Chunks/SctpSackChunk.cs: - ushort numGapAckBlocks = NetConvert.ParseUInt16(buffer, startPosn + 8); (:141) - ushort numDuplicateTSNs = NetConvert.ParseUInt16(buffer, startPosn + 10); (:142) - gap-ack loop (:146) and duplicate-TSN loop (:154) index the buffer via NetConvert.ParseUInt16/32 (buffer[posn], no bounds check — sys/Net/NetConvert.cs:30,41).…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jwjp-4649-v8jp
- Revision 1 · created ·
Published from osv record GHSA-jwjp-4649-v8jp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-jwjp-4649-v8jp Advisory: SIPSorcery vulnerable to Denial of Service via out-of-bounds read in SCTP SACK chunk parsing IDs: GHSA-jwjp-4649-v8jp Record: https://patchnext.com/advisories/ghsa-jwjp-4649-v8jp (revision 2, source checked 26 Oct 2026, 17:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sipsorcery 10.0.14. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet sipsorcery: affected <= 10.0.13; fixed in 10.0.14 ## Suggested inspection (read-only) - NuGet sipsorcery: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sipsorcery. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jwjp-4649-v8jp (OSV record GHSA-jwjp-4649-v8jp lists affected ranges: NuGet sipsorcery >=0 <10.0.14 (fixed)) - Verified: https://github.com/advisories/GHSA-jwjp-4649-v8jp (GitHub-reviewed advisory GHSA-jwjp-4649-v8jp lists affected ranges: NuGet sipsorcery >=0 <=10.0.13) Commands are suggestions: review each one before running it.
Loading voting…