Skip to content

← Actionable
Medium, CVSS 6.5amended

SurrealDB: Denial of Service via deep operator chains

CVE-2026-63737GHSA-jv2j-mqmw-xvv5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (surrealdb 3.1.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io surrealdb

    Affected
    >= 3.0.0, < 3.1.5
    Fixed in
    3.1.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-63737: 0.49% estimated exploitation activity in the next 30 days; percentile 41.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An authenticated user could crash a SurrealDB server with a single query containing a long chain of operators. Such a query — for example `RETURN 1 + 1 + 1 + ...` with tens of thousands of terms — is parsed into an expression tree one level deep per operator. Because the chain is flat and the pratt parser appends to it iteratively, the configured query- and object-recursion limits never fire, so the tree grows unbounded with the length of the query. The root cause: the over-deep tree is later walked recursively, one call per node, when it is dropped, formatted, or lowered for execution — overflowing the thread stack and aborting the process.

Impact An authenticated user with query-execution privileges can crash a SurrealDB server with a single query containing a long chain of operators. The whole process aborts, denying service to every namespace and database on that instance until it is restarted. The crash occurs during query processing, before any data is read or written…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-jv2j-mqmw-xvv5

  2. Revision 1 · created ·

    Published from ghsa record GHSA-jv2j-mqmw-xvv5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-63737

Advisory: SurrealDB: Denial of Service via deep operator chains
IDs: CVE-2026-63737, GHSA-jv2j-mqmw-xvv5
Record: https://patchnext.com/advisories/ghsa-jv2j-mqmw-xvv5 (revision 2, source checked 4 Nov 2026, 06:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: surrealdb 3.1.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io surrealdb: affected >= 3.0.0, < 3.1.5; fixed in 3.1.5

## Suggested inspection (read-only)
- crates.io surrealdb: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on surrealdb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jv2j-mqmw-xvv5 (GitHub-reviewed advisory GHSA-jv2j-mqmw-xvv5 lists affected ranges: crates.io surrealdb >=3.0.0 <3.1.5)
- Verified: https://osv.dev/vulnerability/GHSA-jv2j-mqmw-xvv5 (OSV record GHSA-jv2j-mqmw-xvv5 lists affected ranges: crates.io surrealdb >=3.0.0 <3.1.5 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…