Skip to content

← Actionable
Unrated

eZ Platform Bundled jQuery affected by CVE-2019-11358

GHSA-jrpw-8884-2747

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ezsystems/ezplatform-admin-ui-assets 4.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

In eZ Platform 2.x, ezsystems/ezplatform-admin-ui-assets before v4.2.0 includes jQuery version 3.3.1. This version of jQuery is affected by the security vulnerability https://www.cvedetails.com/cve/CVE-2019-11358/ This is fixed in jQuery version 3.4. We recommend that you upgrade your ezsystems/ezplatform-admin-ui-assets to v4.2.0 using Composer. This release includes jQuery 3.4.1.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jrpw-8884-2747

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-jrpw-8884-2747

Advisory: eZ Platform Bundled jQuery affected by CVE-2019-11358
IDs: GHSA-jrpw-8884-2747
Record: https://patchnext.com/advisories/ghsa-jrpw-8884-2747 (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ezsystems/ezplatform-admin-ui-assets 4.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist ezsystems/ezplatform-admin-ui-assets: affected >= 4.0.0, < 4.2.0; fixed in 4.2.0

## Suggested inspection (read-only)
- Packagist ezsystems/ezplatform-admin-ui-assets: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ezsystems/ezplatform-admin-ui-assets.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jrpw-8884-2747 (GitHub-reviewed advisory GHSA-jrpw-8884-2747 lists affected ranges: Packagist ezsystems/ezplatform-admin-ui-assets >=4.0.0 <4.2.0)

Commands are suggestions: review each one before running it.

Loading voting…