Kimai: Username enumeration via timing on X-AUTH-USER
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (kimai/kimai 2.54.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist kimai/kimai
- Affected
- <= 2.53.0
- Fixed in
- 2.54.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jrc6-fmhw-fpq2 lists affected ranges: Packagist kimai/kimai >=0 <=2.53.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Details src/API/Authentication/TokenAuthenticator.php calls loadUserByIdentifier() first and only invokes the password hasher (argon2id) when a user is returned. When the username does not exist, the request returns roughly 25 ms faster than when it does. The response body is the same in both cases ({"message":"Invalid credentials"}, HTTP 403), so the leak is purely timing. The /api/ firewall has no loginthrottling configured, so the probe is unbounded. The legacy X-AUTH-USER / X-AUTH-TOKEN headers are still accepted by default in 2.x. No prior authentication, no API token, and no session cookie are required. Proof of concept Usage: In this run, four real accounts were identified out of thirteen candidates with no false positives or false negatives. Probing took roughly five seconds per username at fifteen samples each. Fix In TokenAuthenticator::authenticate(), run the password hasher against a fixed dummy hash when the user is not found, so the response time does not depend on user…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jrc6-fmhw-fpq2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-jrc6-fmhw-fpq2 Advisory: Kimai: Username enumeration via timing on X-AUTH-USER IDs: GHSA-jrc6-fmhw-fpq2 Record: https://patchnext.com/advisories/ghsa-jrc6-fmhw-fpq2 (revision 1, source checked 26 Oct 2026, 14:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: kimai/kimai 2.54.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist kimai/kimai: affected <= 2.53.0; fixed in 2.54.0 ## Suggested inspection (read-only) - Packagist kimai/kimai: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on kimai/kimai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jrc6-fmhw-fpq2 (GitHub-reviewed advisory GHSA-jrc6-fmhw-fpq2 lists affected ranges: Packagist kimai/kimai >=0 <=2.53.0) Commands are suggestions: review each one before running it.
Loading voting…