Skip to content

← Actionable
Medium, CVSS 6.1

Silverstripe XSS in Director::force_redirect()

GHSA-jqp8-v74p-g8px

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/framework 3.1.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

A low level XSS vulnerability has been found in the Framework affecting http redirection via the Director::forceredirect method. Attempts to redirect to a url may generate HTML which is not safely escaped, and may pose a risk of XSS in some environments. This vulnerability is marked low as it is difficult to exploit, as any injected HTML will only be returned from the server if the Location HTTP header is also sent, meaning that any user browsing the site would not be exposed to the body of the response before their browser redirects them.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jqp8-v74p-g8px

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-jqp8-v74p-g8px

Advisory: Silverstripe XSS in Director::force_redirect()
IDs: GHSA-jqp8-v74p-g8px
Record: https://patchnext.com/advisories/ghsa-jqp8-v74p-g8px (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: silverstripe/framework 3.1.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist silverstripe/framework: affected >= 3.1.0, < 3.1.12; fixed in 3.1.12

## Suggested inspection (read-only)
- Packagist silverstripe/framework: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on silverstripe/framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jqp8-v74p-g8px (GitHub-reviewed advisory GHSA-jqp8-v74p-g8px lists affected ranges: Packagist silverstripe/framework >=3.1.0 <3.1.12)

Commands are suggestions: review each one before running it.

Loading voting…