Skip to content

← Actionable
Critical, CVSS 10.0amended

Vibe-Trading LLM-callable tools permit command execution, code injection, and SSRF

CVE-2026-114107GHSA-jqmf-mx4f-hfr6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vibe-trading-ai 0.1.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-114107: 0.58% estimated exploitation activity in the next 30 days; percentile 47.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary: 5 findings — BashTool shell-injection sink (F6, the canonical RCE primitive), BackgroundRunTool async shell-injection sink (F7), backtest execmodule() runs top-level statements before the SignalEngine class check (F8 — independent RCE path that does not match BashTool signatures), readurl outbound HTTP forwarding without schema/host validation (F-B4 SSRF), and Jinja2 codegen with autoescape disabled for .py.j2 templates (F-B5, defense-in-depth code-injection sink). --- Shared baseline (applies to all 5 findings) All five tools are members of the auto-discovered tool registry the LLM agent gets at startup; the LLM is free to call any of them based on the user prompt. The tool registration is unconditional in default config — no operator opt-in flag gates them. Combined with GHSA-1 / F1 (unauthenticated POST /sessions/{id}/messages), every primitive in this advisory is reachable from any anonymous TCP client to port 8899. The container has no USER directive, so successful…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-jqmf-mx4f-hfr6

  2. Revision 2 · amended ·

    Amended from osv record GHSA-jqmf-mx4f-hfr6

  3. Revision 1 · created ·

    Published from ghsa record GHSA-jqmf-mx4f-hfr6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-114107

Advisory: Vibe-Trading LLM-callable tools permit command execution, code injection, and SSRF
IDs: CVE-2026-114107, GHSA-jqmf-mx4f-hfr6
Record: https://patchnext.com/advisories/ghsa-jqmf-mx4f-hfr6 (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vibe-trading-ai 0.1.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vibe-trading-ai: affected >= 0.1.0, < 0.1.7; fixed in 0.1.7

## Suggested inspection (read-only)
- `python -m pip show vibe-trading-ai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vibe-trading-ai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jqmf-mx4f-hfr6 (GitHub-reviewed advisory GHSA-jqmf-mx4f-hfr6 lists affected ranges: PyPI vibe-trading-ai >=0.1.0 <0.1.7)
- Verified: https://osv.dev/vulnerability/GHSA-jqmf-mx4f-hfr6 (OSV record GHSA-jqmf-mx4f-hfr6 lists affected ranges: PyPI vibe-trading-ai >=0.1.0 <0.1.7 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…