Content object state fetch functions open to SQL injection
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ezsystems/ezpublish-legacy 2019.03.6.1, 2017.12.7.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist ezsystems/ezpublish-legacy
- Affected
- >= 2018.06.0, <= 2019.03.5.1<= 2017.12.7.3
- Fixed in
- 2019.03.6.1, 2017.12.7.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jpwx-ffjq-wr4w lists affected ranges: Packagist ezsystems/ezpublish-legacy >=2018.06.0 =0 <=2017.12.7.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact This Security Update is about a vulnerability in eZ Publish Legacy. The content object state code could be vulnerable to SQL injection. There is no known exploit, but one might be possible. If you use Legacy in any way, we strongly recommend that you install this update as soon as possible. Patches The fix is distributed via Composer, see "Patched versions".
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jpwx-ffjq-wr4w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-jpwx-ffjq-wr4w Advisory: Content object state fetch functions open to SQL injection IDs: GHSA-jpwx-ffjq-wr4w Record: https://patchnext.com/advisories/ghsa-jpwx-ffjq-wr4w (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ezsystems/ezpublish-legacy 2019.03.6.1, 2017.12.7.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist ezsystems/ezpublish-legacy: affected >= 2018.06.0, <= 2019.03.5.1; <= 2017.12.7.3; fixed in 2019.03.6.1, 2017.12.7.4 ## Suggested inspection (read-only) - Packagist ezsystems/ezpublish-legacy: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ezsystems/ezpublish-legacy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jpwx-ffjq-wr4w (GitHub-reviewed advisory GHSA-jpwx-ffjq-wr4w lists affected ranges: Packagist ezsystems/ezpublish-legacy >=2018.06.0 =0 <=2017.12.7.3) Commands are suggestions: review each one before running it.
Loading voting…