Sensitive information exposure through logs in npm-registry-fetch
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (npm-registry-fetch 8.1.1, 4.0.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 4.0.5>= 5.0.0, < 8.1.1
- Fixed in
- 8.1.1, 4.0.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jmqm-f2gx-4fjv lists affected ranges: npm npm-registry-fetch >=0 =5.0.0 <8.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jmqm-f2gx-4fjv lists affected ranges: npm npm-registry-fetch >=0 =5.0.0 <8.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Affected versions of npm-registry-fetch are vulnerable to an information exposure vulnerability through log files. The cli supports URLs like <protocol://[<user[:<password]@]<hostname[:<port][:][/]<path. The password value is not redacted and is printed to stdout and also to any generated log files.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jmqm-f2gx-4fjv
- Revision 1 · created ·
Published from osv record GHSA-jmqm-f2gx-4fjv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-jmqm-f2gx-4fjv Advisory: Sensitive information exposure through logs in npm-registry-fetch IDs: GHSA-jmqm-f2gx-4fjv Record: https://patchnext.com/advisories/ghsa-jmqm-f2gx-4fjv (revision 2, source checked 26 Oct 2026, 12:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: npm-registry-fetch 8.1.1, 4.0.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm npm-registry-fetch: affected < 4.0.5; >= 5.0.0, < 8.1.1; fixed in 8.1.1, 4.0.5 ## Suggested inspection (read-only) - `npm ls npm-registry-fetch --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on npm-registry-fetch. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jmqm-f2gx-4fjv (OSV record GHSA-jmqm-f2gx-4fjv lists affected ranges: npm npm-registry-fetch >=0 =5.0.0 <8.1.1 (fixed)) - Verified: https://github.com/advisories/GHSA-jmqm-f2gx-4fjv (GitHub-reviewed advisory GHSA-jmqm-f2gx-4fjv lists affected ranges: npm npm-registry-fetch >=0 =5.0.0 <8.1.1) Commands are suggestions: review each one before running it.
Loading voting…