Skip to content

← Actionable
Unratedamended

pyca/cryptography's wheels include vulnerable OpenSSL

GHSA-jm77-qphf-c4w8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cryptography 41.0.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in cryptography 0.8-41.0.2 are vulnerable to several security issues. More details about the vulnerabilities themselves can be found in https://www.openssl.org/news/secadv/20230731.txt, https://www.openssl.org/news/secadv/20230719.txt, and https://www.openssl.org/news/secadv/20230714.txt. If you are building cryptography source ("sdist") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jm77-qphf-c4w8

  2. Revision 1 · created ·

    Published from osv record GHSA-jm77-qphf-c4w8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-jm77-qphf-c4w8

Advisory: pyca/cryptography's wheels include vulnerable OpenSSL
IDs: GHSA-jm77-qphf-c4w8
Record: https://patchnext.com/advisories/ghsa-jm77-qphf-c4w8 (revision 2, source checked 26 Oct 2026, 13:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cryptography 41.0.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI cryptography: affected >= 0.8, < 41.0.3; fixed in 41.0.3

## Suggested inspection (read-only)
- `python -m pip show cryptography`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cryptography.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jm77-qphf-c4w8 (OSV record GHSA-jm77-qphf-c4w8 lists affected ranges: PyPI cryptography >=0.8 <41.0.3 (fixed))
- Verified: https://github.com/advisories/GHSA-jm77-qphf-c4w8 (GitHub-reviewed advisory GHSA-jm77-qphf-c4w8 lists affected ranges: PyPI cryptography >=0.8 <41.0.3)

Commands are suggestions: review each one before running it.

Loading voting…