Skip to content

← Actionable
Medium, CVSS 6.5amended

Wagtail: Improper restriction handling on Page translation API endpoint

GHSA-jm5p-837g-rv8g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wagtail 8.0rc2, 7.4.3, 7.3.4, 7.0.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI wagtail

    Affected
    < 7.0.9>= 7.1rc1, < 7.3.4>= 7.4rc1, < 7.4.3>= 8.0rc1, < 8.0rc2
    Fixed in
    7.3.4, 7.0.9, 8.0rc2, 7.4.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact A CMS user with the "submit translations" permission, could use the Admin API's "copy for translation" endpoint to copy an existing page that they do not have edit access to, allowing them to view its contents.

Patches Patched versions have been released as Wagtail 7.0.9, 7.3.4, 7.4.3 and 8.0rc2.

Workarounds N/A

Acknowledgements Many thanks to tinyb0y for reporting this issue.

For more information If you have any questions or comments about this advisory: * Visit Wagtail's support channels * Email us at security@wagtail.org (view our security policy for more information).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from osv record GHSA-jm5p-837g-rv8g

  2. Revision 2 · amended ·

    Amended from ghsa record GHSA-jm5p-837g-rv8g

  3. Revision 1 · created ·

    Published from ghsa record GHSA-jm5p-837g-rv8g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-jm5p-837g-rv8g

Advisory: Wagtail: Improper restriction handling on Page translation API endpoint
IDs: GHSA-jm5p-837g-rv8g
Record: https://patchnext.com/advisories/ghsa-jm5p-837g-rv8g (revision 3, source checked 27 Oct 2026, 06:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wagtail 8.0rc2, 7.4.3, 7.3.4, 7.0.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI wagtail: affected < 7.0.9; >= 7.1rc1, < 7.3.4; >= 7.4rc1, < 7.4.3; >= 8.0rc1, < 8.0rc2; fixed in 7.3.4, 7.0.9, 8.0rc2, 7.4.3

## Suggested inspection (read-only)
- `python -m pip show wagtail`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wagtail.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jm5p-837g-rv8g (GitHub-reviewed advisory GHSA-jm5p-837g-rv8g lists affected ranges: PyPI wagtail >=0 =7.1 =7.4 =8.0rc1 <=8.0rc1)
- Verified: https://github.com/advisories/GHSA-jm5p-837g-rv8g (GitHub-reviewed advisory GHSA-jm5p-837g-rv8g lists affected ranges: PyPI wagtail >=0 =8.0rc1 =7.1rc1 =7.4rc1 <7.4.3)
- Verified: https://osv.dev/vulnerability/GHSA-jm5p-837g-rv8g (OSV record GHSA-jm5p-837g-rv8g lists affected ranges: PyPI wagtail >=0 =7.1rc1 =7.4rc1 =8.0rc1 <8.0rc2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…