Komari vulnerable to 2FA Authentication Bypass
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/komari-monitor/komari 0.0.0-20250809064056-cc3d54bff4c6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/komari-monitor/komari
- Affected
- < 0.0.0-20250809064056-cc3d54bff4c6
- Fixed in
- 0.0.0-20250809064056-cc3d54bff4c6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jhmr-57cj-q6g9 lists affected ranges: Go github.com/komari-monitor/komari >=0 <0.0.0-20250809064056-cc3d54bff4c6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary Logic error in 2FA verification condition allows bypass of two-factor authentication Details https://github.com/komari-monitor/komari/blob/bd5a6934e1b79a12cf1e6a9bba5372d0e04f3abc/api/login.go#L55 There is no way for Verify2Fa to return an error AND true as ok at the same time, any codes are considered as valid. PoC Use any 6 digits as 2FA code Impact Bypass 2FA Authentication
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jhmr-57cj-q6g9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-jhmr-57cj-q6g9 Advisory: Komari vulnerable to 2FA Authentication Bypass IDs: GHSA-jhmr-57cj-q6g9 Record: https://patchnext.com/advisories/ghsa-jhmr-57cj-q6g9 (revision 1, source checked 26 Oct 2026, 15:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/komari-monitor/komari 0.0.0-20250809064056-cc3d54bff4c6. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/komari-monitor/komari: affected < 0.0.0-20250809064056-cc3d54bff4c6; fixed in 0.0.0-20250809064056-cc3d54bff4c6 ## Suggested inspection (read-only) - Go github.com/komari-monitor/komari: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/komari-monitor/komari. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jhmr-57cj-q6g9 (GitHub-reviewed advisory GHSA-jhmr-57cj-q6g9 lists affected ranges: Go github.com/komari-monitor/komari >=0 <0.0.0-20250809064056-cc3d54bff4c6) Commands are suggestions: review each one before running it.
Loading voting…