k8saudit shipped rules do not detect privileged/sensitive settings on init or ephemeral containers
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/falcosecurity/plugins/plugins/k8saudit 0.18.0; github.com/falcosecurity/plugins/plugins/k8saudit-ovh 0.6.0; github.com/falcosecurity/plugins/plugins/k8saudit-eks 0.12.0; github.com/falcosecurity/plugins/plugins/k8saudit-aks 0.6.0; github.com/falcosecurity/plugins/plugins/k8saudit-gke 0.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/falcosecurity/plugins/plugins/k8saudit
- Affected
- <= 0.17.0
- Fixed in
- 0.18.0
Go github.com/falcosecurity/plugins/plugins/k8saudit-ovh
- Affected
- <= 0.5.0
- Fixed in
- 0.6.0
Go github.com/falcosecurity/plugins/plugins/k8saudit-eks
- Affected
- <= 0.11.0
- Fixed in
- 0.12.0
Go github.com/falcosecurity/plugins/plugins/k8saudit-aks
- Affected
- <= 0.5.1
- Fixed in
- 0.6.0
Go github.com/falcosecurity/plugins/plugins/k8saudit-gke
- Affected
- <= 0.8.0
- Fixed in
- 0.9.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jhjp-4c2q-xmx4 lists affected ranges: Go github.com/falcosecurity/plugins/plugins/k8saudit >=0 =0 =0 =0 =0 <0.6.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6538 lists affected ranges: Go github.com/falcosecurity/plugins/plugins/k8saudit >=0 =0 =0 =0 =0 <0.6.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jhjp-4c2q-xmx4 lists affected ranges: Go github.com/falcosecurity/plugins/plugins/k8saudit >=0 =0 =0 =0 =0 <=0.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
The k8saudit plugin's per-container fields (ka.req.pod.containers.) and the shipped k8sauditrules.yaml evaluated only requestObject.spec.containers. Security-relevant settings on a pod's initContainers or ephemeralContainers were not inspected, so the shipped Create Privileged Pod rule did not fire for a privileged container placed in either list. Impact An actor able to create pods (the activity k8saudit is intended to audit) could run a privileged container without triggering the default Create Privileged Pod rule, by declaring it as an initContainer or ephemeralContainer instead of a regular container. Kubernetes runs such containers with the requested privileges, but the shipped rule did not see them. The same gap applied to other per-container security settings (capabilities, allowPrivilegeEscalation, runAsUser, etc.) and, for deployments using a customized image allowlist, to disallowed images placed in those lists. This is a detection bypass of the default k8saudit ruleset,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jhjp-4c2q-xmx4
- Revision 2 · amended ·
Amended from osv record GO-2026-6538
- Revision 1 · created ·
Published from osv record GHSA-jhjp-4c2q-xmx4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-jhjp-4c2q-xmx4 Advisory: k8saudit shipped rules do not detect privileged/sensitive settings on init or ephemeral containers IDs: GHSA-jhjp-4c2q-xmx4 Record: https://patchnext.com/advisories/ghsa-jhjp-4c2q-xmx4 (revision 3, source checked 26 Oct 2026, 15:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/falcosecurity/plugins/plugins/k8saudit 0.18.0; github.com/falcosecurity/plugins/plugins/k8saudit-ovh 0.6.0; github.com/falcosecurity/plugins/plugins/k8saudit-eks 0.12.0; github.com/falcosecurity/plugins/plugins/k8saudit-aks 0.6.0; github.com/falcosecurity/plugins/plugins/k8saudit-gke 0.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/falcosecurity/plugins/plugins/k8saudit: affected <= 0.17.0; fixed in 0.18.0 - Go github.com/falcosecurity/plugins/plugins/k8saudit-ovh: affected <= 0.5.0; fixed in 0.6.0 - Go github.com/falcosecurity/plugins/plugins/k8saudit-eks: affected <= 0.11.0; fixed in 0.12.0 - Go github.com/falcosecurity/plugins/plugins/k8saudit-aks: affected <= 0.5.1; fixed in 0.6.0 - Go github.com/falcosecurity/plugins/plugins/k8saudit-gke: affected <= 0.8.0; fixed in 0.9.0 ## Suggested inspection (read-only) - Go github.com/falcosecurity/plugins/plugins/k8saudit: check the installed version with your package manager. - Go github.com/falcosecurity/plugins/plugins/k8saudit-ovh: check the installed version with your package manager. - Go github.com/falcosecurity/plugins/plugins/k8saudit-eks: check the installed version with your package manager. - Go github.com/falcosecurity/plugins/plugins/k8saudit-aks: check the installed version with your package manager. - Go github.com/falcosecurity/plugins/plugins/k8saudit-gke: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/falcosecurity/plugins/plugins/k8saudit, github.com/falcosecurity/plugins/plugins/k8saudit-ovh, github.com/falcosecurity/plugins/plugins/k8saudit-eks, github.com/falcosecurity/plugins/plugins/k8saudit-aks, github.com/falcosecurity/plugins/plugins/k8saudit-gke. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jhjp-4c2q-xmx4 (OSV record GHSA-jhjp-4c2q-xmx4 lists affected ranges: Go github.com/falcosecurity/plugins/plugins/k8saudit >=0 =0 =0 =0 =0 <0.6.0 (fixed)) - Verified: https://osv.dev/vulnerability/GO-2026-6538 (OSV record GO-2026-6538 lists affected ranges: Go github.com/falcosecurity/plugins/plugins/k8saudit >=0 =0 =0 =0 =0 <0.6.0 (fixed)) - Verified: https://github.com/advisories/GHSA-jhjp-4c2q-xmx4 (GitHub-reviewed advisory GHSA-jhjp-4c2q-xmx4 lists affected ranges: Go github.com/falcosecurity/plugins/plugins/k8saudit >=0 =0 =0 =0 =0 <=0.5.0) Commands are suggestions: review each one before running it.
Loading voting…