Zoo Design Studio: Recursive KCL parsing is vulnerable to denial-of-service
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zoo-kcl 0.3.129; kcl-lib 0.3.129), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jgvr-6x5w-hx5w lists affected ranges: PyPI zoo-kcl >=0 =0 <0.3.129 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jgvr-6x5w-hx5w lists affected ranges: PyPI zoo-kcl >=0 <0.3.129
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact Feeding a KCL program that wraps an expression in deep, unnecessary parentheses triggers the parser’s recursive expression - unnecessarilybracketed - expression path. With enough nesting, the call stack grows until it exceeds the process stack limit, causing a stack overflow.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jgvr-6x5w-hx5w
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-jgvr-6x5w-hx5w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-jgvr-6x5w-hx5w Advisory: Zoo Design Studio: Recursive KCL parsing is vulnerable to denial-of-service IDs: GHSA-jgvr-6x5w-hx5w Record: https://patchnext.com/advisories/ghsa-jgvr-6x5w-hx5w (revision 3, source checked 26 Oct 2026, 13:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zoo-kcl 0.3.129; kcl-lib 0.3.129. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI zoo-kcl: affected < 0.3.129; fixed in 0.3.129 - crates.io kcl-lib: affected < 0.3.129; fixed in 0.3.129 ## Suggested inspection (read-only) - `python -m pip show zoo-kcl`: prints the installed version. Run with the environment that serves production active. - crates.io kcl-lib: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zoo-kcl, kcl-lib. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jgvr-6x5w-hx5w (OSV record GHSA-jgvr-6x5w-hx5w lists affected ranges: PyPI zoo-kcl >=0 =0 <0.3.129 (fixed)) - Verified: https://github.com/advisories/GHSA-jgvr-6x5w-hx5w (GitHub-reviewed advisory GHSA-jgvr-6x5w-hx5w lists affected ranges: PyPI zoo-kcl >=0 <0.3.129) Commands are suggestions: review each one before running it.
Loading voting…