fast-copy: Stack exhaustion in fast-copy when copying deeply-nested values
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-copy 4.1.0, 3.1.0, 2.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm fast-copy
- Affected
- >= 4.0.0, < 4.1.0>= 3.0.0, < 3.1.0< 2.2.0
- Fixed in
- 3.1.0, 2.2.0, 4.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jggr-w7fw-pc2j lists affected ranges: npm fast-copy >=4.0.0 =3.0.0 =0 <2.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jggr-w7fw-pc2j lists affected ranges: npm fast-copy >=4.0.0 =3.0.0 =0 <2.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary fast-copy traverses values recursively with no bound on depth. Copying a sufficiently deeply-nested value exhausts the JavaScript call stack and throws a native RangeError: Maximum call stack size exceeded from inside the library. Details Both copy and copyStrict recurse once per level of nesting. The value does not need to be circular (circular references were already handled correctly via an internal cache) and it does not need to be large. A plain object nested a few thousand levels deep is only a few kilobytes of equivalent JSON. Measured depths at which copying begins to fail (Node.js, V8; the exact ceiling varies with JIT state and the stack available to the environment): | Call | Last depth that copies successfully | | -------------------- | ----------------------------------- | | copy(object) | 2811 | | copy(array) | 3983 | | copyStrict(object) | 1874 | | copyStrict(array) | 1874 | JSON.parse is iterative and parses deeply-nested input without difficulty, so a payload…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-jggr-w7fw-pc2j
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-jggr-w7fw-pc2j
- Revision 1 · created ·
Published from ghsa record GHSA-jggr-w7fw-pc2j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-jggr-w7fw-pc2j Advisory: fast-copy: Stack exhaustion in fast-copy when copying deeply-nested values IDs: GHSA-jggr-w7fw-pc2j Record: https://patchnext.com/advisories/ghsa-jggr-w7fw-pc2j (revision 4, source checked 26 Oct 2026, 13:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fast-copy 4.1.0, 3.1.0, 2.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm fast-copy: affected >= 4.0.0, < 4.1.0; >= 3.0.0, < 3.1.0; < 2.2.0; fixed in 3.1.0, 2.2.0, 4.1.0 ## Suggested inspection (read-only) - `npm ls fast-copy --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fast-copy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jggr-w7fw-pc2j (GitHub-reviewed advisory GHSA-jggr-w7fw-pc2j lists affected ranges: npm fast-copy >=4.0.0 =3.0.0 =0 <2.2.0) - Verified: https://osv.dev/vulnerability/GHSA-jggr-w7fw-pc2j (OSV record GHSA-jggr-w7fw-pc2j lists affected ranges: npm fast-copy >=4.0.0 =3.0.0 =0 <2.2.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…