Authorizer: CQL/N1QL Injection in Cassandra and Couchbase Backends via fmt.Sprintf String Interpolation
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/authorizerdev/authorizer 0.0.0-20260327055742-73679faa53cd), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/authorizerdev/authorizer
- Affected
- < 0.0.0-20260327055742-73679faa53cd
- Fixed in
- 0.0.0-20260327055742-73679faa53cd
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jfwg-rxf3-p7r9 lists affected ranges: Go github.com/authorizerdev/authorizer >=0 <0.0.0-20260327055742-73679faa53cd
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Vulnerability Details CWE: CWE-943 - Improper Neutralization of Special Elements in Data Query Logic All 66+ CQL queries in internal/storage/db/cassandradb/ use fmt.Sprintf to interpolate user-controlled values directly into CQL query strings without parameterization. Unauthenticated endpoints (signup, login, forgotpassword, magiclinklogin) pass user input directly into CQL query strings. Note: This advisory covers the Cassandra CQL injection only. The Couchbase N1QL injection is tracked in a separate advisory per CVE rule 4.2.11. Affected Code Pattern Steps to Reproduce 1. Deploy Authorizer <= 2.0.0 with Cassandra backend 2. Send a signup request with a CQL injection payload in the email field: 3. The single quote breaks out of the CQL string literal, causing a CQL parse error that leaks internal schema information 4. Crafted payloads can manipulate query logic to bypass authentication or extract data Affected Files (10 Cassandra files) | Package | File | Queries Fixed |…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jfwg-rxf3-p7r9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-jfwg-rxf3-p7r9 Advisory: Authorizer: CQL/N1QL Injection in Cassandra and Couchbase Backends via fmt.Sprintf String Interpolation IDs: GHSA-jfwg-rxf3-p7r9 Record: https://patchnext.com/advisories/ghsa-jfwg-rxf3-p7r9 (revision 1, source checked 26 Oct 2026, 15:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/authorizerdev/authorizer 0.0.0-20260327055742-73679faa53cd. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/authorizerdev/authorizer: affected < 0.0.0-20260327055742-73679faa53cd; fixed in 0.0.0-20260327055742-73679faa53cd ## Suggested inspection (read-only) - Go github.com/authorizerdev/authorizer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/authorizerdev/authorizer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jfwg-rxf3-p7r9 (GitHub-reviewed advisory GHSA-jfwg-rxf3-p7r9 lists affected ranges: Go github.com/authorizerdev/authorizer >=0 <0.0.0-20260327055742-73679faa53cd) Commands are suggestions: review each one before running it.
Loading voting…