Skip to content

← Actionable
High, CVSS 7.5amended

league/commonmark: Denial of service via duplicate footnote definitions

GHSA-jfm3-95jq-q3rf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (league/commonmark 2.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact The Footnote extension records one backref per footnote reference and then appends the entire backref list for every footnote definition block in the document, without ever de-duplicating or removing repeated definitions of the same label (GatherFootnotesListener, populated by NumberFootnotesListener). A document that references a single label N times and also supplies N duplicate [^a]: definitions of that label therefore produces N × N FootnoteBackref nodes, so output size, parse time, and peak memory are all O(N²). Reaching the vulnerable path requires FootnoteExtension to be registered on the Environment. This is opt-in, but is a commonly enabled GFM-style feature; no other non-default configuration is required. An unauthenticated attacker can expand a ~10 KB request into a ~62 MB HTML response, ~3 s of CPU, and ~440 MB of peak memory — enough to OOM-kill a default 128 MB PHP worker and deny service. Availability impact only; no confidentiality or integrity effect. The…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jfm3-95jq-q3rf

  2. Revision 1 · created ·

    Published from osv record GHSA-jfm3-95jq-q3rf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-jfm3-95jq-q3rf

Advisory: league/commonmark: Denial of service via duplicate footnote definitions
IDs: GHSA-jfm3-95jq-q3rf
Record: https://patchnext.com/advisories/ghsa-jfm3-95jq-q3rf (revision 2, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: league/commonmark 2.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist league/commonmark: affected >= 1.5.0, < 2.9.0; fixed in 2.9.0

## Suggested inspection (read-only)
- Packagist league/commonmark: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on league/commonmark.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jfm3-95jq-q3rf (OSV record GHSA-jfm3-95jq-q3rf lists affected ranges: Packagist league/commonmark >=1.5.0 <2.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-jfm3-95jq-q3rf (GitHub-reviewed advisory GHSA-jfm3-95jq-q3rf lists affected ranges: Packagist league/commonmark >=1.5.0 <2.9.0)

Commands are suggestions: review each one before running it.

Loading voting…