Cross-Site Scripting in mavon-editor
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mavon-editor 2.8.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm mavon-editor
- Affected
- < 2.8.2
- Fixed in
- 2.8.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jfcc-rm7f-xgf8 lists affected ranges: npm mavon-editor >=0 <2.8.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jfcc-rm7f-xgf8 lists affected ranges: npm mavon-editor >=0 <2.8.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
All versions of mavon-editor are vulnerable to Cross-Site Scripting. The package fails to sanitize entered input, allowing attackers to execute arbitrary JavaScript in a victim's browser. Recommendation No fix is currently available. Consider using an alternative package until a fix is made available.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jfcc-rm7f-xgf8
- Revision 1 · created ·
Published from osv record GHSA-jfcc-rm7f-xgf8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-jfcc-rm7f-xgf8 Advisory: Cross-Site Scripting in mavon-editor IDs: GHSA-jfcc-rm7f-xgf8 Record: https://patchnext.com/advisories/ghsa-jfcc-rm7f-xgf8 (revision 2, source checked 26 Oct 2026, 12:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mavon-editor 2.8.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm mavon-editor: affected < 2.8.2; fixed in 2.8.2 ## Suggested inspection (read-only) - `npm ls mavon-editor --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mavon-editor. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jfcc-rm7f-xgf8 (OSV record GHSA-jfcc-rm7f-xgf8 lists affected ranges: npm mavon-editor >=0 <2.8.2 (fixed)) - Verified: https://github.com/advisories/GHSA-jfcc-rm7f-xgf8 (GitHub-reviewed advisory GHSA-jfcc-rm7f-xgf8 lists affected ranges: npm mavon-editor >=0 <2.8.2) Commands are suggestions: review each one before running it.
Loading voting…