Skip to content

← Actionable
High, CVSS 8.1

PHP JWT Framework: JWSVerifier uses algorithm from unprotected header, enabling algorithm confusion attacks

GHSA-jc38-x7x8-2xc8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (web-token/jwt-bundle 4.1.7, 4.0.7, 3.4.10; web-token/jwt-experimental 4.1.7, 4.0.7, 3.4.10; web-token/jwt-library 4.1.7, 4.0.7, 3.4.10; web-token/jwt-framework 4.1.7, 4.0.7, 3.4.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-jc38-x7x8-2xc8 lists affected ranges: Packagist web-token/jwt-library >=0 =4.0.0 =4.1.0 =0 =4.0.0 =4.1.0 =0 =4.0.0 =4.1.0 =0 =4.0.0 =4.1.0 <4.1.7

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.1 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:P · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary JWSVerifier::getAlgorithm() in src/Library/Signature/JWSVerifier.php (line 144) merges protected and unprotected headers using PHP's spread operator: In PHP, when spreading arrays with duplicate string keys, the last array's values take precedence. Since the unprotected header (getHeader()) is spread second, an attacker can override the integrity-protected alg parameter by placing a different value in the unprotected header. This creates a Time-of-Check/Time-of-Use (TOCTOU) vulnerability: 1. HeaderCheckerManager validates alg from the protected header 2. JWSVerifier uses alg from the unprotected header for actual verification The same issue exists in JWEDecrypter.php (lines 120-124) where arraymerge() exhibits the same last-wins behavior for alg and enc. Affected Code JWSVerifier.php line 144 — Spread operator merge order allows unprotected header to override alg: JWEDecrypter.php lines 120-124 — arraymerge() with same last-wins behavior: Attack Vectors Vector A — Mixed key…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jc38-x7x8-2xc8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-jc38-x7x8-2xc8

Advisory: PHP JWT Framework: JWSVerifier uses algorithm from unprotected header, enabling algorithm confusion attacks
IDs: GHSA-jc38-x7x8-2xc8
Record: https://patchnext.com/advisories/ghsa-jc38-x7x8-2xc8 (revision 1, source checked 26 Oct 2026, 14:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: web-token/jwt-bundle 4.1.7, 4.0.7, 3.4.10; web-token/jwt-experimental 4.1.7, 4.0.7, 3.4.10; web-token/jwt-library 4.1.7, 4.0.7, 3.4.10; web-token/jwt-framework 4.1.7, 4.0.7, 3.4.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist web-token/jwt-bundle: affected < 3.4.10; >= 4.0.0, < 4.0.7; >= 4.1.0, < 4.1.7; fixed in 4.0.7, 3.4.10, 4.1.7
- Packagist web-token/jwt-experimental: affected < 3.4.10; >= 4.0.0, < 4.0.7; >= 4.1.0, < 4.1.7; fixed in 4.0.7, 3.4.10, 4.1.7
- Packagist web-token/jwt-library: affected < 3.4.10; >= 4.0.0, < 4.0.7; >= 4.1.0, < 4.1.7; fixed in 4.0.7, 3.4.10, 4.1.7
- Packagist web-token/jwt-framework: affected < 3.4.10; >= 4.0.0, < 4.0.7; >= 4.1.0, < 4.1.7; fixed in 4.0.7, 3.4.10, 4.1.7

## Suggested inspection (read-only)
- Packagist web-token/jwt-bundle: check the installed version with your package manager.
- Packagist web-token/jwt-experimental: check the installed version with your package manager.
- Packagist web-token/jwt-library: check the installed version with your package manager.
- Packagist web-token/jwt-framework: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on web-token/jwt-bundle, web-token/jwt-experimental, web-token/jwt-library, web-token/jwt-framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jc38-x7x8-2xc8 (GitHub-reviewed advisory GHSA-jc38-x7x8-2xc8 lists affected ranges: Packagist web-token/jwt-library >=0 =4.0.0 =4.1.0 =0 =4.0.0 =4.1.0 =0 =4.0.0 =4.1.0 =0 =4.0.0 =4.1.0 <4.1.7)

Commands are suggestions: review each one before running it.

Loading voting…