Skip to content

← Actionable
Low, CVSS 2.9

ImageMagick: Memory Leak in hough lines operation when an operation fails

GHSA-j8rh-v2r8-v94x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (magick.net-q8-arm64 14.15.0; magick.net-q8-x86 14.15.0; magick.net-q16-hdri-anycpu 14.15.0; magick.net-q16-openmp-x64 14.15.0; magick.net-q16-anycpu 14.15.0; 12 more packages under Affected packages), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-j8rh-v2r8-v94x lists affected ranges: NuGet magick.net-q16-anycpu >=0 =0 =0 =0 =0 =0 =0 =0 =0 <14.15.0; NuGet magick.net-q16-x86…

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.9 · CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

When a specific operation fails in the hough lines operation a small memory leak will occur.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j8rh-v2r8-v94x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-j8rh-v2r8-v94x

Advisory: ImageMagick: Memory Leak in hough lines operation when an operation fails
IDs: GHSA-j8rh-v2r8-v94x
Record: https://patchnext.com/advisories/ghsa-j8rh-v2r8-v94x (revision 1, source checked 26 Oct 2026, 17:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: magick.net-q8-arm64 14.15.0; magick.net-q8-x86 14.15.0; magick.net-q16-hdri-anycpu 14.15.0; magick.net-q16-openmp-x64 14.15.0; magick.net-q16-anycpu 14.15.0; magick.net-q16-hdri-x86 14.15.0; magick.net-q16-hdri-openmp-arm64 14.15.0; magick.net-q16-hdri-arm64 14.15.0; magick.net-q16-x86 14.15.0; magick.net-q8-openmp-x64 14.15.0; magick.net-q16-openmp-arm64 14.15.0; magick.net-q16-x64 14.15.0; magick.net-q8-x64 14.15.0; magick.net-q8-openmp-arm64 14.15.0; magick.net-q8-anycpu 14.15.0; magick.net-q16-arm64 14.15.0; magick.net-q16-hdri-x64 14.15.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet magick.net-q8-arm64: affected < 14.15.0; fixed in 14.15.0
- NuGet magick.net-q8-x86: affected < 14.15.0; fixed in 14.15.0
- NuGet magick.net-q16-hdri-anycpu: affected < 14.15.0; fixed in 14.15.0
- NuGet magick.net-q16-openmp-x64: affected < 14.15.0; fixed in 14.15.0
- NuGet magick.net-q16-anycpu: affected < 14.15.0; fixed in 14.15.0
- NuGet magick.net-q16-hdri-x86: affected < 14.15.0; fixed in 14.15.0
- NuGet magick.net-q16-hdri-openmp-arm64: affected < 14.15.0; fixed in 14.15.0
- NuGet magick.net-q16-hdri-arm64: affected < 14.15.0; fixed in 14.15.0
- NuGet magick.net-q16-x86: affected < 14.15.0; fixed in 14.15.0
- NuGet magick.net-q8-openmp-x64: affected < 14.15.0; fixed in 14.15.0
- NuGet magick.net-q16-openmp-arm64: affected < 14.15.0; fixed in 14.15.0
- NuGet magick.net-q16-x64: affected < 14.15.0; fixed in 14.15.0
- NuGet magick.net-q8-x64: affected < 14.15.0; fixed in 14.15.0
- NuGet magick.net-q8-openmp-arm64: affected < 14.15.0; fixed in 14.15.0
- NuGet magick.net-q8-anycpu: affected < 14.15.0; fixed in 14.15.0
- NuGet magick.net-q16-arm64: affected < 14.15.0; fixed in 14.15.0
- NuGet magick.net-q16-hdri-x64: affected < 14.15.0; fixed in 14.15.0

## Suggested inspection (read-only)
- NuGet magick.net-q8-arm64: check the installed version with your package manager.
- NuGet magick.net-q8-x86: check the installed version with your package manager.
- NuGet magick.net-q16-hdri-anycpu: check the installed version with your package manager.
- NuGet magick.net-q16-openmp-x64: check the installed version with your package manager.
- NuGet magick.net-q16-anycpu: check the installed version with your package manager.
- NuGet magick.net-q16-hdri-x86: check the installed version with your package manager.
- NuGet magick.net-q16-hdri-openmp-arm64: check the installed version with your package manager.
- NuGet magick.net-q16-hdri-arm64: check the installed version with your package manager.
- NuGet magick.net-q16-x86: check the installed version with your package manager.
- NuGet magick.net-q8-openmp-x64: check the installed version with your package manager.
- NuGet magick.net-q16-openmp-arm64: check the installed version with your package manager.
- NuGet magick.net-q16-x64: check the installed version with your package manager.
- NuGet magick.net-q8-x64: check the installed version with your package manager.
- NuGet magick.net-q8-openmp-arm64: check the installed version with your package manager.
- NuGet magick.net-q8-anycpu: check the installed version with your package manager.
- NuGet magick.net-q16-arm64: check the installed version with your package manager.
- NuGet magick.net-q16-hdri-x64: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on magick.net-q8-arm64, magick.net-q8-x86, magick.net-q16-hdri-anycpu, magick.net-q16-openmp-x64, magick.net-q16-anycpu, magick.net-q16-hdri-x86, magick.net-q16-hdri-openmp-arm64, magick.net-q16-hdri-arm64, magick.net-q16-x86, magick.net-q8-openmp-x64, magick.net-q16-openmp-arm64, magick.net-q16-x64, magick.net-q8-x64, magick.net-q8-openmp-arm64, magick.net-q8-anycpu, magick.net-q16-arm64, magick.net-q16-hdri-x64.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j8rh-v2r8-v94x (GitHub-reviewed advisory GHSA-j8rh-v2r8-v94x lists affected ranges: NuGet magick.net-q16-anycpu >=0 =0 =0 =0 =0 =0 =0 =0 =0 <14.15.0; NuGet magick.net-q16-x86…)

Commands are suggestions: review each one before running it.

Loading voting…