Skip to content

← Actionable
Unratedamended

Prevent logging invalid header values

GHSA-j5g3-5c8r-7qfx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@apollo/server 4.9.3; apollo-server-core 3.12.1, 2.26.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact What kind of vulnerability is it? Apollo Server can log sensitive information (Studio API keys) if they are passed incorrectly (with leading/trailing whitespace) or if they have any characters that are invalid as part of a header value. Who is impacted? Users who (all of the below): use either the schema reporting or usage reporting feature use an Apollo Studio API key which has invalid header values use the default fetcher (node-fetch) or configured their own node-fetch fetcher The following node snippet can test whether your API key has invalid header values. This code is taken directly from node-fetch@2's header value validation code. If the provided API key is not a valid header value, whenever Apollo Server uses that API key in a request (to Studio, for example), node-fetch will throw an error which contains the header value. This error is logged in various ways depending on the user's configuration, but most likely the console or some configured logging service. Patches…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-j5g3-5c8r-7qfx

  2. Revision 1 · created ·

    Published from osv record GHSA-j5g3-5c8r-7qfx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-j5g3-5c8r-7qfx

Advisory: Prevent logging invalid header values
IDs: GHSA-j5g3-5c8r-7qfx
Record: https://patchnext.com/advisories/ghsa-j5g3-5c8r-7qfx (revision 2, source checked 26 Oct 2026, 12:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @apollo/server 4.9.3; apollo-server-core 3.12.1, 2.26.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @apollo/server: affected < 4.9.3; fixed in 4.9.3
- npm apollo-server-core: affected >= 3.0.0, < 3.12.1; < 2.26.1; fixed in 2.26.1, 3.12.1

## Suggested inspection (read-only)
- `npm ls @apollo/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls apollo-server-core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @apollo/server, apollo-server-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j5g3-5c8r-7qfx (OSV record GHSA-j5g3-5c8r-7qfx lists affected ranges: npm @apollo/server >=0 =3.0.0 =0 <2.26.1 (fixed))
- Verified: https://github.com/advisories/GHSA-j5g3-5c8r-7qfx (GitHub-reviewed advisory GHSA-j5g3-5c8r-7qfx lists affected ranges: npm @apollo/server >=0 =3.0.0 =0 <2.26.1)

Commands are suggestions: review each one before running it.

Loading voting…