rusty_paseto vulnerable to private key extraction due to ed25519-dalek dependency
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rusty-paseto 0.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io rusty-paseto
- Affected
- <= 0.5.0
- Fixed in
- 0.6.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j57r-4qw6-58r3 lists affected ranges: crates.io rusty-paseto >=0 <=0.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact The vulnerability, known as RUSTSEC-2022-0093, impacts the ed25519-dalek crate, which is a dependency of the rusty-paseto crate. This issue arises from a "Double Public Key Signing Function Oracle Attack" affecting versions of ed25519-dalek prior to v2.0. These versions expose an unsafe API for serializing and deserializing 64-byte keypairs that include both private and public keys, creating potential for certain attacks. d25519-dalek users utilizing these serialization and deserialization functions directly could potentially be impacted. Patches The vulnerability within the ed25519-dalek crate has been addressed in version 2.0. rusty-paseto has addressed it in release v0.6.0. Workarounds Users are recommended to upgrade to v0.6.0 of rusty-paseto. However, users should still ensure that their key serialization and deserialization practices are secure and avoid any practices that could lead to key exposure. References More information about RUSTSEC-2022-0093 can be found in the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j57r-4qw6-58r3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-j57r-4qw6-58r3 Advisory: rusty_paseto vulnerable to private key extraction due to ed25519-dalek dependency IDs: GHSA-j57r-4qw6-58r3 Record: https://patchnext.com/advisories/ghsa-j57r-4qw6-58r3 (revision 1, source checked 26 Oct 2026, 15:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rusty-paseto 0.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io rusty-paseto: affected <= 0.5.0; fixed in 0.6.0 ## Suggested inspection (read-only) - crates.io rusty-paseto: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rusty-paseto. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j57r-4qw6-58r3 (GitHub-reviewed advisory GHSA-j57r-4qw6-58r3 lists affected ranges: crates.io rusty-paseto >=0 <=0.5.0) Commands are suggestions: review each one before running it.
Loading voting…