OMERO.web uses jquery-form library, which may be vulnerable to XSS attack
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (omero-web 5.29.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI omero-web
- Affected
- < 5.29.3
- Fixed in
- 5.29.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j4gv-6x9v-v23g lists affected ranges: PyPI omero-web >=0 <5.29.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j4gv-6x9v-v23g lists affected ranges: PyPI omero-web >=0 <5.29.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact OMERO.web uses the jquery-form library throughout to handle form submission and response processing. Due to some unpatched potential vulnerabilities in jquery-form, OMERO.web 5.29.2 and earlier may be susceptible to XSS attacks. Patches User should upgrade OMERO.web to 5.29.3 or higher. Workarounds None. Resources https://github.com/jquery-form/form/issues/604
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-j4gv-6x9v-v23g
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-j4gv-6x9v-v23g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-j4gv-6x9v-v23g Advisory: OMERO.web uses jquery-form library, which may be vulnerable to XSS attack IDs: GHSA-j4gv-6x9v-v23g Record: https://patchnext.com/advisories/ghsa-j4gv-6x9v-v23g (revision 3, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: omero-web 5.29.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI omero-web: affected < 5.29.3; fixed in 5.29.3 ## Suggested inspection (read-only) - `python -m pip show omero-web`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on omero-web. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-j4gv-6x9v-v23g (OSV record GHSA-j4gv-6x9v-v23g lists affected ranges: PyPI omero-web >=0 <5.29.3 (fixed)) - Verified: https://github.com/advisories/GHSA-j4gv-6x9v-v23g (GitHub-reviewed advisory GHSA-j4gv-6x9v-v23g lists affected ranges: PyPI omero-web >=0 <5.29.3) Commands are suggestions: review each one before running it.
Loading voting…