Skip to content

← Actionable
Low, CVSS 3.2amended

dbt-core's secret env vars written to package-lock.json in plaintext

GHSA-j4g3-3q8x-jxqp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dbt-core 1.7.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI dbt-core

    Affected
    >= 1.7.0, < 1.7.3
    Fixed in
    1.7.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.2 · CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:L/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact When used to pull source code from a private repository using a Personal Access Token (PAT), some versions of dbt-core write a URL with the PAT in plaintext to the package-lock.yml file. Patches The bug has been fixed in dbt-core v1.7.3. Mitigations Remove any git URLs with plaintext secrets from package-lock.yml file(s) on servers, workstations, or in source control. Rotate any tokens that have been written to version-controlled files.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-j4g3-3q8x-jxqp

  2. Revision 1 · created ·

    Published from osv record GHSA-j4g3-3q8x-jxqp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-j4g3-3q8x-jxqp

Advisory: dbt-core's secret env vars written to package-lock.json in plaintext
IDs: GHSA-j4g3-3q8x-jxqp
Record: https://patchnext.com/advisories/ghsa-j4g3-3q8x-jxqp (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dbt-core 1.7.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI dbt-core: affected >= 1.7.0, < 1.7.3; fixed in 1.7.3

## Suggested inspection (read-only)
- `python -m pip show dbt-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dbt-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j4g3-3q8x-jxqp (OSV record GHSA-j4g3-3q8x-jxqp lists affected ranges: PyPI dbt-core >=1.7.0 <1.7.3 (fixed))
- Verified: https://github.com/advisories/GHSA-j4g3-3q8x-jxqp (GitHub-reviewed advisory GHSA-j4g3-3q8x-jxqp lists affected ranges: PyPI dbt-core >=1.7.0 <1.7.3)

Commands are suggestions: review each one before running it.

Loading voting…