zlib-rs stack overflow during decompression with malicious input
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zlib-rs 0.4.0; libz-rs-sys-cdylib 0.4.0; libz-rs-sys 0.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io zlib-rs
- Affected
- <= 0.3.1
- Fixed in
- 0.4.0
crates.io libz-rs-sys-cdylib
- Affected
- <= 0.3.1
- Fixed in
- 0.4.0
crates.io libz-rs-sys
- Affected
- <= 0.3.1
- Fixed in
- 0.4.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j3px-q95c-9683 lists affected ranges: crates.io zlib-rs >=0 =0 =0 <=0.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
A denial of service vulnerability was found in zlib-rs, triggered by specially constructed input. This input causes a stack overflow, resulting in the process using zlib-rs to crash. Impact Due to the way LLVM handles the zlib-rs codebase, tail calls were not guaranteed. This caused certain input patterns to result in a large number of stack frames being required, quickly resulting in a stack overflow. These are unlikely to occur in practice, but a dedicated attacker can construct malicious input files. After stack overflows were found by @inahga with a fuzzer, we dove into the assembly, and found some cases where the stack grew LLVM wants to centralize the cleanup before the return (many other blocks jump to LBB109311), thereby invalidating a tail call to typedo. We were not able to get rid of this call without introducing one elsewhere: we just don't currently have the power to tell LLVM what we want it to do. So, we switch back to loop+match waiting for changes to rust to make a…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j3px-q95c-9683
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-j3px-q95c-9683 Advisory: zlib-rs stack overflow during decompression with malicious input IDs: GHSA-j3px-q95c-9683 Record: https://patchnext.com/advisories/ghsa-j3px-q95c-9683 (revision 1, source checked 26 Oct 2026, 15:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zlib-rs 0.4.0; libz-rs-sys-cdylib 0.4.0; libz-rs-sys 0.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io zlib-rs: affected <= 0.3.1; fixed in 0.4.0 - crates.io libz-rs-sys-cdylib: affected <= 0.3.1; fixed in 0.4.0 - crates.io libz-rs-sys: affected <= 0.3.1; fixed in 0.4.0 ## Suggested inspection (read-only) - crates.io zlib-rs: check the installed version with your package manager. - crates.io libz-rs-sys-cdylib: check the installed version with your package manager. - crates.io libz-rs-sys: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zlib-rs, libz-rs-sys-cdylib, libz-rs-sys. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j3px-q95c-9683 (GitHub-reviewed advisory GHSA-j3px-q95c-9683 lists affected ranges: crates.io zlib-rs >=0 =0 =0 <=0.3.1) Commands are suggestions: review each one before running it.
Loading voting…