Multiple security issues in Pomerium's embedded envoy
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/pomerium/pomerium 0.16.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/pomerium/pomerium
- Affected
- < 0.16.4
- Fixed in
- 0.16.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j34v-3552-5r7j lists affected ranges: Go github.com/pomerium/pomerium >=0 <0.16.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Envoy, which Pomerium is based on, has issued multiple CVEs impacting stability and security. Though Pomerium may not be vulnerable to all of the issues, it is recommended that all users upgrade to Pomerium v0.16.4 as soon as possible to minimize risk. Impact - Possible DoS or crash - Resources available to unauthorized users - Pomerium may trust upstream certificates that should not be trusted Patches Patched in v0.16.4 Workarounds No References Envoy Security Announcement CVE-2021-43824 (CVSS Score 6.5, Medium): Envoy 1.21.0 and earlier - Potential null pointer dereference when using JWT filter saferegex match CVE-2021-43825 (CVSS Score 6.1, Medium): Envoy 1.21.0 and earlier - Use-after-free when response filters increase response data, and increased data exceeds downstream buffer limits. CVE-2021-43826 (CVSS Score 6.1, Medium): Envoy 1.21.0 and earlier - Use-after-free when tunneling TCP over HTTP, if downstream disconnects during upstream connection establishment CVE-2022-21654…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j34v-3552-5r7j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-j34v-3552-5r7j Advisory: Multiple security issues in Pomerium's embedded envoy IDs: GHSA-j34v-3552-5r7j Record: https://patchnext.com/advisories/ghsa-j34v-3552-5r7j (revision 1, source checked 26 Oct 2026, 14:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/pomerium/pomerium 0.16.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/pomerium/pomerium: affected < 0.16.4; fixed in 0.16.4 ## Suggested inspection (read-only) - Go github.com/pomerium/pomerium: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/pomerium/pomerium. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j34v-3552-5r7j (GitHub-reviewed advisory GHSA-j34v-3552-5r7j lists affected ranges: Go github.com/pomerium/pomerium >=0 <0.16.4) Commands are suggestions: review each one before running it.
Loading voting…