Skip to content

← Actionable
High, CVSS 8.8amended

Komari: Management Interface CSRF

GHSA-hxjg-93wc-h8p8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/komari-monitor/komari 0.0.0-20260609084633-98122fa4d110), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Vulnerability Overview The sessiontoken cookie is set without the SameSite or Secure attributes (login.go:68). All /api/admin/ management endpoints rely solely on this cookie for authentication, with no CSRF token or Origin validation. The server-side vulnerability is confirmed to exist; however, exploitation via cross-site requests is mitigated in modern browsers by the default SameSite=Lax behavior. Root Cause Gin's ShouldBindJSON does not strictly validate the Content-Type header, allowing text/plain requests to bypass CORS preflight. Browser Limitations - Chrome 80+ (Feb 2020), Firefox 103+ (Jul 2022), and Safari all default unspecified cookies to SameSite=Lax. - Cookies without an explicit SameSite attribute are not included in cross-site POST requests. - As a result, the server receives requests without the session cookie and returns HTTP 401 Unauthorized. | Scenario | Exploitable | |----------|-------------| | Cross-site HTML (modern browsers) | ✗ Blocked by SameSite=Lax | |…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-hxjg-93wc-h8p8

  2. Revision 2 · amended ·

    Amended from osv record GO-2026-6449

  3. Revision 1 · created ·

    Published from osv record GHSA-hxjg-93wc-h8p8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-hxjg-93wc-h8p8

Advisory: Komari: Management Interface CSRF
IDs: GHSA-hxjg-93wc-h8p8
Record: https://patchnext.com/advisories/ghsa-hxjg-93wc-h8p8 (revision 3, source checked 26 Oct 2026, 15:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/komari-monitor/komari 0.0.0-20260609084633-98122fa4d110. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/komari-monitor/komari: affected < 0.0.0-20260609084633-98122fa4d110; fixed in 0.0.0-20260609084633-98122fa4d110

## Suggested inspection (read-only)
- Go github.com/komari-monitor/komari: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/komari-monitor/komari.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hxjg-93wc-h8p8 (OSV record GHSA-hxjg-93wc-h8p8 lists affected ranges: Go github.com/komari-monitor/komari >=0 <0.0.0-20260609084633-98122fa4d110 (fixed))
- Verified: https://osv.dev/vulnerability/GO-2026-6449 (OSV record GO-2026-6449 lists affected ranges: Go github.com/komari-monitor/komari >=0 <0.0.0-20260609084633-98122fa4d110 (fixed))
- Verified: https://github.com/advisories/GHSA-hxjg-93wc-h8p8 (GitHub-reviewed advisory GHSA-hxjg-93wc-h8p8 lists affected ranges: Go github.com/komari-monitor/komari >=0 <0.0.0-20260609084633-98122fa4d110)

Commands are suggestions: review each one before running it.

Loading voting…