namshi/jose insecure JSON Web Signatures (JWS)
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (namshi/jose 2.1.2, 2.0.3, 1.2.2, 1.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist namshi/jose
- Affected
- < 1.1.2>= 1.2.0, < 1.2.2>= 2.0.0, < 2.0.3>= 2.1.0, < 2.1.2
- Fixed in
- 2.0.3, 1.2.2, 2.1.2, 1.1.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hxhc-wmg8-xrqf lists affected ranges: Packagist namshi/jose >=0 =1.2.0 =2.0.0 =2.1.0 <2.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
namshi/jose allows the acceptance of unsecure JSON Web Signatures (JWS) by default. The vulnerability arises from the $allowUnsecure flag, which, when set to true during the loading of JWSes, permits tokens signed with 'none' algorithms to be processed. This behavior poses a significant security risk as it could allow an attacker to impersonate users by crafting a valid jwt token.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hxhc-wmg8-xrqf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-hxhc-wmg8-xrqf Advisory: namshi/jose insecure JSON Web Signatures (JWS) IDs: GHSA-hxhc-wmg8-xrqf Record: https://patchnext.com/advisories/ghsa-hxhc-wmg8-xrqf (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: namshi/jose 2.1.2, 2.0.3, 1.2.2, 1.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist namshi/jose: affected < 1.1.2; >= 1.2.0, < 1.2.2; >= 2.0.0, < 2.0.3; >= 2.1.0, < 2.1.2; fixed in 2.0.3, 1.2.2, 2.1.2, 1.1.2 ## Suggested inspection (read-only) - Packagist namshi/jose: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on namshi/jose. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hxhc-wmg8-xrqf (GitHub-reviewed advisory GHSA-hxhc-wmg8-xrqf lists affected ranges: Packagist namshi/jose >=0 =1.2.0 =2.0.0 =2.1.0 <2.1.2) Commands are suggestions: review each one before running it.
Loading voting…