SQL Injection in sails-mysql
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sails-mysql 0.10.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm sails-mysql
- Affected
- < 0.10.8
- Fixed in
- 0.10.8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hx5x-49mm-vmhw lists affected ranges: npm sails-mysql >=0 <0.10.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hx5x-49mm-vmhw lists affected ranges: npm sails-mysql >=0 <0.10.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Versions of sails-mysql prior to 0.10.8 are vulnerable to SQL Injection. The sort keyword is not properly sanitized and may allow attackers to inject SQL statements and execute arbitrary SQL queries Recommendation Upgrade to version 0.10.8 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hx5x-49mm-vmhw
- Revision 1 · created ·
Published from osv record GHSA-hx5x-49mm-vmhw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-hx5x-49mm-vmhw Advisory: SQL Injection in sails-mysql IDs: GHSA-hx5x-49mm-vmhw Record: https://patchnext.com/advisories/ghsa-hx5x-49mm-vmhw (revision 2, source checked 26 Oct 2026, 12:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sails-mysql 0.10.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm sails-mysql: affected < 0.10.8; fixed in 0.10.8 ## Suggested inspection (read-only) - `npm ls sails-mysql --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sails-mysql. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hx5x-49mm-vmhw (OSV record GHSA-hx5x-49mm-vmhw lists affected ranges: npm sails-mysql >=0 <0.10.8 (fixed)) - Verified: https://github.com/advisories/GHSA-hx5x-49mm-vmhw (GitHub-reviewed advisory GHSA-hx5x-49mm-vmhw lists affected ranges: npm sails-mysql >=0 <0.10.8) Commands are suggestions: review each one before running it.
Loading voting…