ZendFramework local file inclusion vector in Zend_View::setScriptPath() and render()
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zendframework/zendframework1 1.7.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist zendframework/zendframework1
- Affected
- >= 1.7.0, < 1.7.5
- Fixed in
- 1.7.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hx3m-959f-v849 lists affected ranges: Packagist zendframework/zendframework1 >=1.7.0 <1.7.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
ZendView is a component that utilizes PHP as a templating language. To utilize it, you specify "script paths" that contain view scripts, and then render() view scripts by specifying subdirectories within those script paths; the output is then returned as a string value which may be cached or directly output. ZendView::setScriptPath() in versions up to and including 1.7.4 include a potential Local File Inclusion vulnerability. If untrusted input is used to specify the script path and/or view script itself, a malicious attacker could potentially specify a system directory and thus render a system file. As an example, if the user-supplied string /etc/passwd or a relative path that resolved to that file, was supplied to ZendView::render(), that file would be rendered.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hx3m-959f-v849
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-hx3m-959f-v849 Advisory: ZendFramework local file inclusion vector in `Zend_View::setScriptPath()` and `render()` IDs: GHSA-hx3m-959f-v849 Record: https://patchnext.com/advisories/ghsa-hx3m-959f-v849 (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zendframework/zendframework1 1.7.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist zendframework/zendframework1: affected >= 1.7.0, < 1.7.5; fixed in 1.7.5 ## Suggested inspection (read-only) - Packagist zendframework/zendframework1: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zendframework/zendframework1. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hx3m-959f-v849 (GitHub-reviewed advisory GHSA-hx3m-959f-v849 lists affected ranges: Packagist zendframework/zendframework1 >=1.7.0 <1.7.5) Commands are suggestions: review each one before running it.
Loading voting…