Skip to content

← Actionable
Medium, CVSS 5.4amended

devbridge-autocomplete has XSS in its default formatters: formatGroup and formatResult fail to escape HTML in untrusted inputs

GHSA-hvqh-jw65-wcpq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (devbridge-autocomplete 2.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary The default formatGroup and formatResult functions in devbridge-autocomplete concatenate values into HTML without escaping, allowing XSS when an attacker controls (or can taint) the suggestion data source. Details 1. formatGroup — category is interpolated raw. src/format.ts: If groupBy is used and the grouping field of any suggestion contains HTML, that HTML is executed. 2. formatResult — early-return branch returns suggestion.value raw. src/format.ts: The early-return branch is reached when suggest() renders with an empty currentValue, which happens with minChars: 0 and a server that returns suggestions for an empty query. The returned string is concatenated into the container's innerHTML. PoC (formatGroup) Originally identified by an earlier human analysis; the PoC above was produced with the assistance of Claude Opus 4.7. Impact XSS in pages that render attacker-controllable suggestion data. The actual impact depends on what the embedding page has access to (cookies,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hvqh-jw65-wcpq

  2. Revision 1 · created ·

    Published from osv record GHSA-hvqh-jw65-wcpq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-hvqh-jw65-wcpq

Advisory: devbridge-autocomplete has XSS in its default formatters: formatGroup and formatResult fail to escape HTML in untrusted inputs
IDs: GHSA-hvqh-jw65-wcpq
Record: https://patchnext.com/advisories/ghsa-hvqh-jw65-wcpq (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: devbridge-autocomplete 2.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm devbridge-autocomplete: affected <= 2.0.0; fixed in 2.0.1

## Suggested inspection (read-only)
- `npm ls devbridge-autocomplete --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on devbridge-autocomplete.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hvqh-jw65-wcpq (OSV record GHSA-hvqh-jw65-wcpq lists affected ranges: npm devbridge-autocomplete >=0 <2.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-hvqh-jw65-wcpq (GitHub-reviewed advisory GHSA-hvqh-jw65-wcpq lists affected ranges: npm devbridge-autocomplete >=0 <=2.0.0)

Commands are suggestions: review each one before running it.

Loading voting…