Skip to content

← Actionable
High, CVSS 7.1amended

OpenClaw Hook Session Key Override Enables Targeted Cross-Session Routing

GHSA-hv93-r4j3-q65f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    >= 2.0.0-beta3, < 2026.2.12
    Fixed in
    2026.2.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary The issue is not deterministic session keys by itself. The exploitable path was accepting externally supplied sessionKey values on authenticated hook ingress, allowing a hook token holder to route messages into chosen sessions. Affected Behavior - POST /hooks/agent accepted payload sessionKey and used it directly for session routing. - Common session-key shapes (for example agent:main:dm:<peerId) were often derivable from known metadata, making targeted routing practical when request-level override was enabled. Attack Preconditions - Attacker can call hook endpoints with a valid hook token. - Hook ingress allows request-selected sessionKey values. - Target session keys can be derived or guessed. Without those preconditions, deterministic key formats alone do not provide access. Impact - Integrity: targeted message/prompt injection into chosen sessions. - Persistence: poisoned context can affect subsequent turns when the same session key is reused. - Confidentiality impact is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hv93-r4j3-q65f

  2. Revision 1 · created ·

    Published from osv record GHSA-hv93-r4j3-q65f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-hv93-r4j3-q65f

Advisory: OpenClaw Hook Session Key Override Enables Targeted Cross-Session Routing
IDs: GHSA-hv93-r4j3-q65f
Record: https://patchnext.com/advisories/ghsa-hv93-r4j3-q65f (revision 2, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected >= 2.0.0-beta3, < 2026.2.12; fixed in 2026.2.12

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hv93-r4j3-q65f (OSV record GHSA-hv93-r4j3-q65f lists affected ranges: npm openclaw >=2.0.0-beta3 <2026.2.12 (fixed))
- Verified: https://github.com/advisories/GHSA-hv93-r4j3-q65f (GitHub-reviewed advisory GHSA-hv93-r4j3-q65f lists affected ranges: npm openclaw >=2.0.0-beta3 <2026.2.12)

Commands are suggestions: review each one before running it.

Loading voting…