Skip to content

← Actionable
Critical, CVSS 9.1amended

uv's bundled CA store trusts an emSign root whose intermediate CA keys are compromised

GHSA-hq85-5cpj-mr62

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (uv 0.13.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI uv

    Affected
    < 0.13.4
    Fixed in
    0.13.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.1 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

By default, uv verifies TLS connections against a vendored copy of the webpki-root-certs bundle. Versions before 0.13.4 include the emSign ECC Root CA - G3 root. Eight eMudhra intermediate CA certificates that chain to that root have compromised private keys, and the CA has revoked them. An attacker with one of the compromised keys can issue certificates that uv accepts for any hostname, and can be used to issue certificates to enable MITM attacks. uv 0.13.4 removes the root from its vendored bundle, following webpki-root-certs 1.0.10. Upgrade to 0.13.4 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-hq85-5cpj-mr62

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-hq85-5cpj-mr62

  4. Revision 1 · created ·

    Published from ghsa record GHSA-hq85-5cpj-mr62

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-hq85-5cpj-mr62

Advisory: uv's bundled CA store trusts an emSign root whose intermediate CA keys are compromised
IDs: GHSA-hq85-5cpj-mr62
Record: https://patchnext.com/advisories/ghsa-hq85-5cpj-mr62 (revision 4, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: uv 0.13.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI uv: affected < 0.13.4; fixed in 0.13.4

## Suggested inspection (read-only)
- `python -m pip show uv`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on uv.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hq85-5cpj-mr62 (GitHub-reviewed advisory GHSA-hq85-5cpj-mr62 lists affected ranges: PyPI uv >=0 <0.13.4)
- Verified: https://osv.dev/vulnerability/GHSA-hq85-5cpj-mr62 (OSV record GHSA-hq85-5cpj-mr62 lists affected ranges: PyPI uv >=0 <0.13.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…