Winter: Reflected XSS through the search query parameter in the backend Table widget
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (winter/wn-backend-module 1.2.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist winter/wn-backend-module
- Affected
- >= 1.0.420, <= 1.2.13
- Fixed in
- 1.2.14
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hq84-x37p-j6q5 lists affected ranges: Packagist winter/wn-backend-module >=1.0.420 <1.2.14 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hq84-x37p-j6q5 lists affected ranges: Packagist winter/wn-backend-module >=1.0.420 <=1.2.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:H/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact Affected versions of Winter CMS render the search query parameter without HTML encoding inside a <script type="text/template" block in the backend Table widget partial (modules/backend/widgets/table/partials/table.php): <script is an HTML raw-text context, so the surrounding value="…" attribute quoting is not a parser boundary. A literal </script in the query string terminates the template element early, and everything after it is parsed as ordinary markup in the backend document. Any backend page rendering a Table or DataTable widget is a sink. The value is read from the global request through the get() helper, which — unlike post() — is not restricted by HTTP method, so a plain top-level GET navigation is sufficient. The template is also emitted unconditionally by the partial, so widgets using the default searching: false configuration are equally affected. In Winter core the reachable route is the Editor Settings form (/backend/system/settings/update/winter/backend/editor),…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hq84-x37p-j6q5
- Revision 1 · created ·
Published from osv record GHSA-hq84-x37p-j6q5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-hq84-x37p-j6q5 Advisory: Winter: Reflected XSS through the search query parameter in the backend Table widget IDs: GHSA-hq84-x37p-j6q5 Record: https://patchnext.com/advisories/ghsa-hq84-x37p-j6q5 (revision 2, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: winter/wn-backend-module 1.2.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist winter/wn-backend-module: affected >= 1.0.420, <= 1.2.13; fixed in 1.2.14 ## Suggested inspection (read-only) - Packagist winter/wn-backend-module: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on winter/wn-backend-module. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hq84-x37p-j6q5 (OSV record GHSA-hq84-x37p-j6q5 lists affected ranges: Packagist winter/wn-backend-module >=1.0.420 <1.2.14 (fixed)) - Verified: https://github.com/advisories/GHSA-hq84-x37p-j6q5 (GitHub-reviewed advisory GHSA-hq84-x37p-j6q5 lists affected ranges: Packagist winter/wn-backend-module >=1.0.420 <=1.2.13) Commands are suggestions: review each one before running it.
Loading voting…