Skip to content

← Actionable
Medium, CVSS 6.0amended

Pocket ID has a reauthentication bypass via one-time access token login — passkey step-up requirement defeated by JWT freshness check that accepts any login method

GHSA-hp74-gm6m-2qm5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/pocket-id/pocket-id/backend 0.0.0-20260419162744-978ac87deffe), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Reauthentication Bypass via One-Time Access Token Login Summary A weaker authentication method (OTA token or signup token) is accepted as passkey step-up proof, yielding unauthorized renewable 30-day OIDC refresh tokens for clients explicitly configured with RequiresReauthentication: true. The POST /api/webauthn/reauthenticate endpoint's access-token fallback checks only JWT freshness (IssuedAt within 60 seconds), not the authentication method used. The session cookie gate is also non-validating -- any arbitrary cookie value (e.g. session=deadbeef) is accepted, collapsing the reauth boundary to token recency alone. The bypass needs to succeed only once. The resulting OIDC grant includes a 30-day refresh token that can be rotated indefinitely, providing persistent victim-impersonation access to the protected downstream service. The attacker obtains accesstoken (1-hour TTL), idtoken (victim's name, email, profile), and refreshtoken (30-day TTL, renewable) for a client that was…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-hp74-gm6m-2qm5

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GO-2026-6117

  4. Revision 1 · created ·

    Published from osv record GHSA-hp74-gm6m-2qm5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-hp74-gm6m-2qm5

Advisory: Pocket ID has a reauthentication bypass via one-time access token login — passkey step-up requirement defeated by JWT freshness check that accepts any login method
IDs: GHSA-hp74-gm6m-2qm5
Record: https://patchnext.com/advisories/ghsa-hp74-gm6m-2qm5 (revision 4, source checked 26 Oct 2026, 15:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/pocket-id/pocket-id/backend 0.0.0-20260419162744-978ac87deffe. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/pocket-id/pocket-id/backend: affected < 0.0.0-20260419162744-978ac87deffe; fixed in 0.0.0-20260419162744-978ac87deffe

## Suggested inspection (read-only)
- Go github.com/pocket-id/pocket-id/backend: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/pocket-id/pocket-id/backend.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hp74-gm6m-2qm5 (OSV record GHSA-hp74-gm6m-2qm5 lists affected ranges: Go github.com/pocket-id/pocket-id/backend >=0 <0.0.0-20260419162744-978ac87deffe (fixed))
- Verified: https://osv.dev/vulnerability/GO-2026-6117 (OSV record GO-2026-6117 lists affected ranges: Go github.com/pocket-id/pocket-id/backend >=0 <0.0.0-20260419162744-978ac87deffe (fixed))
- Verified: https://github.com/advisories/GHSA-hp74-gm6m-2qm5 (GitHub-reviewed advisory GHSA-hp74-gm6m-2qm5 lists affected ranges: Go github.com/pocket-id/pocket-id/backend >=0 <0.0.0-20260419162744-978ac87deffe)

Commands are suggestions: review each one before running it.

Loading voting…