GraphQL Armor Max-Depth Plugin Bypass via Introspection Query Obfuscation
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@escape.tech/graphql-armor-max-depth 2.4.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @escape.tech/graphql-armor-max-depth
- Affected
- <= 2.4.1
- Fixed in
- 2.4.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hmfr-rx46-4jx2 lists affected ranges: npm @escape.tech/graphql-armor-max-depth >=0 <2.4.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hmfr-rx46-4jx2 lists affected ranges: npm @escape.tech/graphql-armor-max-depth >=0 <=2.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary A query depth restriction using the max-depth property can be bypassed if ignoreIntrospection is enabled (which is the default configuration) by naming your query/fragment schema. Details At the start of the countDepth function, we have the following check for the ignoreIntrospection option: However, the node can be one of: FieldNode, FragmentDefinitionNode, InlineFragmentNode, OperationDefinitionNode, FragmentSpreadNode. For example, consider sending the following query: This would create an OperationDefinitionNode where node.name.value == 'hello' The proper way to handle this is to check explicitly for the schema field, which corresponds to a FieldNode. The fix is This ensures that the node is explicitly a FieldNode. PoC Max depth: 6 Impact This issue affects applications using the GraphQL Armor Depth Limit plugin with ignoreIntrospection enabled. Fix This is fixed in PR#823
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hmfr-rx46-4jx2
- Revision 1 · created ·
Published from osv record GHSA-hmfr-rx46-4jx2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-hmfr-rx46-4jx2 Advisory: GraphQL Armor Max-Depth Plugin Bypass via Introspection Query Obfuscation IDs: GHSA-hmfr-rx46-4jx2 Record: https://patchnext.com/advisories/ghsa-hmfr-rx46-4jx2 (revision 2, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @escape.tech/graphql-armor-max-depth 2.4.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @escape.tech/graphql-armor-max-depth: affected <= 2.4.1; fixed in 2.4.2 ## Suggested inspection (read-only) - `npm ls @escape.tech/graphql-armor-max-depth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @escape.tech/graphql-armor-max-depth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hmfr-rx46-4jx2 (OSV record GHSA-hmfr-rx46-4jx2 lists affected ranges: npm @escape.tech/graphql-armor-max-depth >=0 <2.4.2 (fixed)) - Verified: https://github.com/advisories/GHSA-hmfr-rx46-4jx2 (GitHub-reviewed advisory GHSA-hmfr-rx46-4jx2 lists affected ranges: npm @escape.tech/graphql-armor-max-depth >=0 <=2.4.1) Commands are suggestions: review each one before running it.
Loading voting…