Skip to content

← Actionable
Critical, CVSS 10.0amended

fief-server Server-Side Template Injection vulnerability

GHSA-hj8m-9fhf-v7jp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fief-server 0.25.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI fief-server

    Affected
    >= 0.19.0, < 0.25.3
    Fixed in
    0.25.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Server-Side Template Injection Overview of the Vulnerability Server-Side Template Injection (SSTI) is a vulnerability within application templating engines where user input is improperly handled and is embedded into the template, possibly leading code being executed. An attacker can use SSTI to execute code on the underlying system by manipulating values within the embedded template. When code is executed within the underlying system, it can allow an attacker to run permissioned commands under the exploited process, or exploit Cross-Site Scripting (XSS) to run code within the user's browser. Business Impact SSTI can lead to reputational damage for the business due to a loss in confidence and trust by users. If an attacker successfully executes code within the underlying system, it can result in data theft and indirect financial losses. Steps to Reproduce 1. Sign up and login to your account 1. Use a browser to navigate to: email-templates {{URL}} 1. put your payload in Edit Base…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hj8m-9fhf-v7jp

  2. Revision 1 · created ·

    Published from osv record GHSA-hj8m-9fhf-v7jp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-hj8m-9fhf-v7jp

Advisory: fief-server Server-Side Template Injection vulnerability
IDs: GHSA-hj8m-9fhf-v7jp
Record: https://patchnext.com/advisories/ghsa-hj8m-9fhf-v7jp (revision 2, source checked 26 Oct 2026, 13:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fief-server 0.25.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI fief-server: affected >= 0.19.0, < 0.25.3; fixed in 0.25.3

## Suggested inspection (read-only)
- `python -m pip show fief-server`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fief-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hj8m-9fhf-v7jp (OSV record GHSA-hj8m-9fhf-v7jp lists affected ranges: PyPI fief-server >=0.19.0 <0.25.3 (fixed))
- Verified: https://github.com/advisories/GHSA-hj8m-9fhf-v7jp (GitHub-reviewed advisory GHSA-hj8m-9fhf-v7jp lists affected ranges: PyPI fief-server >=0.19.0 <0.25.3)

Commands are suggestions: review each one before running it.

Loading voting…