Skip to content

← Actionable
Medium, CVSS 6.8amended

LiteLLM vulnerable to reflected XSS in /sso/debug/callback

GHSA-hhww-mrg2-969h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (litellm 1.85.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI litellm

    Affected
    >= 1.65.5, < 1.85.0
    Fixed in
    1.85.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary The `/sso/debug/callback` endpoint reflected identity-provider-controlled fields into an inline ` ` block via `json.dumps`, which escapes JSON string syntax but not HTML context characters such as ` `. An IdP-returned string field containing ` ` (for example a user-editable display name) closed the script block and executed attacker JavaScript in the proxy's origin.

Impact Reflected XSS on the LiteLLM proxy origin. The route required no authentication, so an attacker with an account on the configured IdP whose claims pass such strings through verbatim could complete the SSO flow themselves and deliver the resulting callback URL to a logged-in proxy admin. Scripts executing in the proxy origin can read the dashboard session cookie and act with the victim's privileges, up to full admin account takeover.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-hhww-mrg2-969h

  2. Revision 1 · created ·

    Published from ghsa record GHSA-hhww-mrg2-969h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-hhww-mrg2-969h

Advisory: LiteLLM vulnerable to reflected XSS in /sso/debug/callback
IDs: GHSA-hhww-mrg2-969h
Record: https://patchnext.com/advisories/ghsa-hhww-mrg2-969h (revision 2, source checked 28 Oct 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: litellm 1.85.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI litellm: affected >= 1.65.5, < 1.85.0; fixed in 1.85.0

## Suggested inspection (read-only)
- `python -m pip show litellm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on litellm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hhww-mrg2-969h (OSV record GHSA-hhww-mrg2-969h lists affected ranges: PyPI litellm >=1.65.5 <1.85.0 (fixed))
- Verified: https://github.com/advisories/GHSA-hhww-mrg2-969h (GitHub-reviewed advisory GHSA-hhww-mrg2-969h lists affected ranges: PyPI litellm >=1.65.5 <1.85.0)

Commands are suggestions: review each one before running it.

Loading voting…