Skip to content

← Actionable
Unratedamended

Potential XSS in jQuery dependency in Mirador

GHSA-hgwm-pv9h-q5m7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mirador 3.0.0-alpha.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm mirador

    Affected
    <= 2.7.2
    Fixed in
    3.0.0-alpha.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact Mirador users less than v3.0.0 (alpha-rc) versions that have an unpatched jQuery. When adopters update jQuery they will find some of Mirador functionality to be broken. Patches Mirador adopters should update to v3.0.0, no updates exist for v2.x releases. Workarounds Yes, Mirador users could fork and create their own custom build of Mirador and make the bug fixes themselves. References https://github.com/advisories/GHSA-gxr4-xjj5-5px2 https://github.com/advisories/GHSA-jpcq-cgw6-v4j6 https://blog.jquery.com/2020/04/10/jquery-3-5-0-released/ https://jquery.com/upgrade-guide/3.5/

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hgwm-pv9h-q5m7

  2. Revision 1 · created ·

    Published from osv record GHSA-hgwm-pv9h-q5m7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-hgwm-pv9h-q5m7

Advisory: Potential XSS in jQuery dependency in Mirador
IDs: GHSA-hgwm-pv9h-q5m7
Record: https://patchnext.com/advisories/ghsa-hgwm-pv9h-q5m7 (revision 2, source checked 26 Oct 2026, 12:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mirador 3.0.0-alpha.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm mirador: affected <= 2.7.2; fixed in 3.0.0-alpha.0

## Suggested inspection (read-only)
- `npm ls mirador --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mirador.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hgwm-pv9h-q5m7 (OSV record GHSA-hgwm-pv9h-q5m7 lists affected ranges: npm mirador >=0 <3.0.0-alpha.0 (fixed))
- Verified: https://github.com/advisories/GHSA-hgwm-pv9h-q5m7 (GitHub-reviewed advisory GHSA-hgwm-pv9h-q5m7 lists affected ranges: npm mirador >=0 <=2.7.2)

Commands are suggestions: review each one before running it.

Loading voting…